Cannot connect to flathub

I currently seem to be unable to connect to/access flathub (which is a bit inconvenient as I am on MicroOS).

Trying to install or update an app gives me “no such ref ‘XYZ’ in remote flathub” And trying to access flathub in the terminal gives me “Unacceptable TLS certificate”.

There were some updated to flatpak and openssl in the recent updates, so is this a common issue that might have been caused by some of that? And if not, any ideas how to fix it?

I tried adding two different flatpak remotes now and get the same error message. So it seems like the issue with the TLS certificate is on my end, but I still have no idea what to do about it.

A forced reinstall of ca-certificates fixed it. The issue is solved now.