Cannot connect Android phone, MTP support not working in 13.1

No, it’s attached to a working USB 2.0 port. I did try two different ports for good measure but they both work fine with other devices. This system is a home-built 64-bit AMD Athlon II with 8 GB RAM.

On Thu 28 Nov 2013 05:16:01 AM CST, deano ferrari wrote:

scottbomb;2602989 Wrote:
> I downloaded and installed that package, thanks. Unfortunately it’s
> still not working. Tail of dmesg:
> >

> > 154.085046] usb 2-6: new full-speed USB device number 3
using ohci-pci > 154.250069] usb 2-6: device descriptor read/64,
error -62 > 154.516064] usb 2-6: device descriptor read/64, error -62
> 154.774042] usb 2-6: new full-speed USB device number 4 using
ohci-pci > 154.939035] usb 2-6: device descriptor read/64, error -62
> 155.205050] usb 2-6: device descriptor read/64, error -62
> 155.463050] usb 2-6: new full-speed USB device number 5 using
ohci-pci > 155.867038] usb 2-6: device not accepting address 5,
error -62 > 156.024046] usb 2-6: new full-speed USB device number 6
using ohci-pci > 156.428044] usb 2-6: device not accepting address
6, error -62 > 156.428082] hub 2-0:1.0: unable to enumerate USB
device on port 6 >

> >
Simply installing a package like that will not help as I mentioned
previously. (I only explained how to find openSUSE RPMs.) You need to
get to the bottom of the USB error messages, which is why I asked if the
phone is being attached via a hub, or directly to the computer’s USB

Is the device being connected configured in the settings -> developer
options -> USB debugging (should be a check box)?

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.101-0.8-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Yes, USB debugging is turned on.

I re-booted the computer and went into Xubuntu 13.10 and found that I could not connect to it there either. It has connected in the past. Maybe there is a bug in the kernel from a recent release from the Mothership Torvalds? How can I tell for sure? I can say that I’m seeing the SAME ERROR in all 3 distros - SUSE, Xubuntu, and (Live version of) Fedora. However, it still works on the main PC so I think I will install it on that machine and see what happens. I’ll report my results here. Being that tomorrow is Thanksgiving Day in the US, I will likely post my results of this experiment some time this weekend.

I’m ashamed to report that the after installing all of the aforementioned packages and it still didn’t work, the source of the problem ended up being a bad USB cable or connector. I was using a different cable tonight and it worked in all *nix versions. I just wish one of the devices, be it my phone or the computer, would have told me that the cable appeared to be at fault.

Thank you all. I will continue testing openSUSE. And as always, try to keep an eye out for the simplest, though not always the most obvious, causes of troble.

Thanks for the update. It’s always worth swapping ports and cables as part of the diagnostics. :slight_smile:

Glad you got it working :slight_smile:

Just for the record. My MotoG with Droid 4.3 in OS 13.1 KDE works like a dream

You have it too easy :smiley:

I didn’t tell the best bit… The phone…
My Son Chris came home with it this weekend as a gift for me !

I appreciate having had the opportunity to speak to you about my experience in related fields and my future goals.
I shall look forward to hearing from you and wish to thank you again for your courtesy.

Best regards

not difficult to keep up with technology

the mobile phone industry and the most busy agenda at the beginning of the advertised income areas.the companies continually advance technology and constantly produces new phones. carriers which may be added subsequently to the phone casing, accessories and cover parts such as manufactures. All of these parts can be found at the akilliphone. will reveal your charisma will attract attention are all parts of this site.

mobile phone accessories| mobile phone spare parts|