Cannot connect a local printer to VBox

I installed recently opensuse 11.3 and then Virtualbox from Sun Webpage.
I have a local printer connected to one of the usb ports. With 11.2, VBox saw perfectly that printer and I could connect normally to it. Now, VBox sees the printer: if I click on the usb icon in the status bar it appears, but dimmed, and I cannot connect to it.
I tried to disconnect and reconnect the printer physically, but nothing changed.
I don’t know what to do. Can anybody help me?

Has nobody had the same problem?
Any idea would be welcome.

Finally I resolved it.
It was just that the device (in this case /dev/bus/usb/004/003) belonged to a group diferent from vboxusers

chgrp vboxusers /dev/bus/usb/004/003/

and that’s it!

I have the same problem.
I have 3 printers and 2 are faded out cannot access them.
I move my Virtual machine to a new system.
i tried “chgrp vboxusers /dev/bus/usb/004/003/” and 001 002
Still doesn’t work
Suse 11.3
VBox 3.2.12
Any help would be appreciated.

Sorry for the delay. I couldn’t visit the forum in the last week.
See this thread. You have there how I resolved my problem.
Please, tell us if that worked for you too.

I found the fix.
Added lp to the user.
Odd, that I could use one printer not the other two.

Happy Holidays

Glad to know.
Happy Christmas to you too.