Cannot configure the Epson XP-900 ALl in One Printer / Scanner


As I am configuring my new system (replacing Mnjaro) at the moment but I cannot find a working solution to install the scanner of the Epson XP-900 printer/scanner.

Printing works flawlessly but the list of supported scanners omits this one model, reaching up to “XP-860 series”, leading on with “XP-950 series”.

This is a bit peculiar to me as the “epsonscan2” software provided by Epson should support it. (But I tried to use both drivers above without success!).

Now Epson also provides a direct download - supposedly an RPM.

But it is a file with an “.rpm.xar.gz” extension - if I unpack this it’s a folder not an RPM file… - AST can’t handle it. But I am sure that I am missing something very basic here!

Also I checked the OBS - there is an “epsonscan2” package for tumbeweed and it also features the latest version… - but sadly it misses the file “” and won’t install.

A follow up search for the package “libtiff5” within the OBS gives me one option with some “factory staging” (?) repository… - but installing this now fails with “repository not found” …

What a rabbit hole! Now I am lost.

Would a symlink “ >” do the trick?

Please help, I really need to get scanning going… !

Anyway - thanks for reading,

Unpack the rpm.tar.gz and install the rpms inside the folders…
Or use the

1 Like

Thx - I didn’t realize that inside the foders rpm files could be found… -)


Now I installed the rpms successfully (thank you!) but I stiall cannot find the scanner model in the Yast scanner list… hmmm, I am lost again.

Any ideas?

Show what is reported by

scanimage -L

Also, check that the ‘epkowa’ entry is present and uncommented in the /etc/sane.d/dll.conf file. Then try detecting the scanner again.

~> scanimage -L

device `epsonscan2:networkscanner:esci2:network:' is a EPSON network scanner flatbed scanner

Ok, the device is recognised at least. Have you tried scanning with your preferred scanning application?

Hmmm …

No, there is no entry “epkowa”.

But there is an “epson2” entry ( Inow uncommented it!)

Now I started the scanner scan again with Yast and now I found the same scanner twice! Tested both with skanlite and both work… I got:

Epson : PID 111A


Epson : network scanner

They same to work both. But just for my understanding:

Why are there two entries now?
Can I safely remove one of them and in this case how?

On the epson device support page the “epsonscan2” driver was marked as the correct and necessary one…

Not to forget: Thank you both a lot - it’s working now though I have to admit even after reading the SUSE wiki about network scanners twice - I still do not really get it.

The “epsonscan2” driver pack has been provided by epson but now it is used by sane?

So what is the second entry that just says “epson2” as driver and where does it stem from ?

Thanks for your help - I really appreciate!

I think I can answer this myself now…

The sponscan2 package (provided by Epson) delivers the connection to the scanner.

The Yast scanner dialog only shows the scanners provided by the sane-backend.

Now I commented “epson2” in the sane.dll again - now Yast doesn’t find any scanner but using skanlite the epsonscan2 driver is still present and works fine!

It’s a bit confusing but after having no way to network scan now I got two!

Cheers and thx again!

Forget my comments about the epkoea driver. That used to support a number of Epson scanners, but the epsonscan2 backend is likely ok here.

There shouldn’t be any need to use YaST to configure the scanner. Just use a scanning app of your choice. FWW, I like using simple-scan.

There is no need to uncomment the epson2 entry in dll.conf, and this is why you observe two scanners reported.

Aha! Allright then…

So that’s what confused me - the Yast modules telegraph themselves to be the central configuration hub for the entire system - so I tried to rely on them before starting to clutter my installation with individual configuration files and solutions that eventually aren’t manageable anymore. That’s the reason why I moved from Manjaro/Arch to OpenSuse - hoping to get a more consistent system configuration management.

Here, if I may, is one more question about your personal preferences:

In gerneral would you recommend trying to keep configurations rather close to what openSUSE delivers (like the epson2 driver) or do you think it’s more prudent to first grab the company provided drivers (like epsonscan2) instead?

What’s your experience here?

Just for context: I find the out of the box experience with the amdgpu drivers abolutely amazing! So I haven’t even considered trying out the amdgpu-pro drivers provided by the adapter manufacturer… - so I wonder if this might be al good strategy overall for a Tumbleweed system… though this way I might miss out on performance and features?



Is there an expectation and/or a way to mark problems as solved in this forum here?

YaST does provide a lot of centralised conflagration modules, however the YaST scanner config utility is largely unnecessary these days. SANE provides support with a large number of open source backends, included by default, and only occasionally is any configuration necessary. Proprietary backends are provided by some vendors, and usually it is only necessary to explicitly declare that by way of an entry in /etc/sane.d.dll.conf when such a (user space) driver is used.

Where support is provided both by the open source SANE backend and a proprietary one, then it is just a matter of testing the former to ensure reasonable compatibility with one’s scanner hardware. If the hardware is new, it may well only be properly supported by the proprietary backend provided by the vendor. Only occasionally is any explicit manual configuration (in the appropriate backend config file) required to get a particular device recognised.

With respect to your AMD graphics hardware, I recommend starting a new thread with a suitably descriptive title to catch the attention of those that can answer that question meaningfully.

Thanks for the clarification!

I used the graphics driver just as an example … my question isn’t about the graphics driver specifically - I wonder whether for openSUSE in general there is a best practice recommendation about using out of the box or vendor provided drivers.

Sure I can test each one individually but there is more involved - if the included versions for example use the vendor software and make sure the integration is optimal - this would be a strong argument for trying to only use “official” openSUSE drivers, systems and methods.

Coming from Manjaro - this is not the case in my opinion and I often ended up in the situation of system updates breaking vendor software.

I am just curious how seasoned openSUSE users think about and deal with this topic to keep a long term clean and well integrated system.


There isn’t a simple answer to that, and no different to any other distro IMHO. For the most part, where Linux open source driver support is provided by the kernel, there is no need to use proprietary drivers.

Allright! Thank for your input.

Have a good day.
Cheers, jhhh


Since it is not open source, it cannot be included in the kernel.
So it is best to install the drivers.
Read the manual and see if you need to meet dependencies.
Since we know the hardware, preference is given by yast; but for that it has to be detected by itself.
It happens sometimes that it does not detect it, but because it is with usb configuration.

To do this you have to run from the console, the epson scan application (Epson Scan2) and change usb to network and put the printer’s ip).
Once done looking at the settings, they are in a hidden directory in your /home :
HP-OMEN:~ # tree /home/frank/.epsonscan2/
├── Connection
│ └── PreferredInfo.dat
├── Network
│ ├── epsonscan2.conf
│ └── epsonscan2.conf
├── Settings
│ ├── CommonSettings.SF2
│ └── ES0154
│ └── UserSettings.SF2
└──Untitled 1

4 directories, 6 files
And see the files as they have the configuration of network : (/home/frank/.epsonscan2/Network/) :

epsonscan2.conf :

and in : (/home/frank/.epsonscan2/Connection/) :
PreferredInfo.dat :

“Connection”: {
“string”: “”
“ESDisplayName”: {
“string”: “Network Scanner”

Having seen this, run yast scan and now if it should be detected, add it and accept.

Now if epsonscan2 works. , SKanlite, etc…

HP-OMEN:~ # nmap -sP
Starting Nmap 7.92 ( ) at 2023-02-12 23:29 WET
Nmap scan report for
Host is up (0.0024s latency).
MAC Address: 38:1A:52:55:D2:1D (Seiko Epson)
Nmap scan report for
Host is up (0.0049s latency).
MAC Address: 08:60:6E:8E:AA:48 (Asustek Computer)
Nmap scan report for
Host is up (0.00055s latency).
MAC Address: 30:05:5C:0B:41:00 (Brother industries)
Nmap scan report for
Host is up (0.00022s latency).
MAC Address: 10:BF:48:8B:DF:AC (Asustek Computer)
Nmap scan report for
Host is up (0.00011s latency).
MAC Address: 00:D0:4B:94:F6:8F (LA CIE Group)
Nmap scan report for
Host is up.

Nmap scan report for
Host is up (0.0024s latency).
MAC Address: 38:1A:52:55:D2:1D (Seiko Epson) .

Kind regards .

Observations: when the drivers have changing the extension, it works for me to replace it and so I can install it with yast software.
Also, since they are drivers, which does not verify the openSUSE repository, it gives a verification error, that error is ignored, and the drivers, despite this, are functional.
The is the multifunction of epson (scanner, printer, etc…).
Example change mpr to rmp , etc… (it’s just an example) .
There is a possibility that epson scan does not appear, you can when it is executed, pass the icon to the desktop and then create the link.
In yast user, add yourself to bin and lp , when using printer , and remember the ports that you have to add (in tests you can do it with the firewall off and activate it later).

I hope it helps (made with a translator from Spanish to English, sorry if it is not correct).