Cannot configure nvidia-settings with proprietary driver for TNT2 AGP 32 megs

Good afternoon to all.

First off, my box is a P3 800 Mhz, 512 megs of RAM with a Nvidia TNT2 32 megs. I can’t afford a new computer right now, so if that was one of your solution to this problem, it cannot be an option :wink:

I decided to post after a week and a half of reading and headache. I have installed the NVIDIA proprietary driver (NVIDIA-Linux-x86-71.86.15-pkg1.run) that I got from their website. Installed the ‘‘hardway’’ … Blacklisted ‘‘nouveau’’ driver, added nomodeset to boot, changed the kms value in sys/config, ''modprobed it then ‘‘mkinitrd’’. So far, so good.

But now the problem I have is that I cannot access to any settings at all when I start ‘‘nvidia-settings’’. I only have one option tab on the left. I tried to use another display manager and still, it doesn’t detect anything in the S-Video output. I tried a lot of different suggestions that I read but nothing seems to do it. Even reversing to the ‘‘nouveau’’ driver does not make a difference.

Is there something I did wrong or is it simply (as I read in a couple places) that the latest xorg does not support well Nvidia legacy drivers ?

Thank you!

> my box is a P3 800 Mhz, 512 megs of RAM with a Nvidia TNT2
> 32 megs. I can’t afford a new computer right now, so if that was one of
> your solution to this problem, it cannot be an option …
> Is there something I did wrong or is it simply (as I read in a couple
> places) that the latest xorg does not support well Nvidia legacy drivers
> ?

-=WELCOME=- new poster!!

your box just meets the minimum recommended hardware requirements for
11.4, see here http://en.opensuse.org/Hardware_requirements

however, no one has yet (afaik) updated it for version 12.1…

and, just between me and you–i think the “recommended” RAM (1GB) and
about a three times faster CPU is the minimum for either KDE or Gnome…

either KDE or Gnome may creep along, hang, pause, spit and sputter and
frustrate you on your current hardware…

so, if buying a different machine is not an option then you should
strongly consider these options:

  1. run a distribution made_for yesteryear’s machines…i’d bet Puppy
    Linux or D@mnSmall Linux will absolutely FLY on your hardware…and both
    are fully supported with security patches and a wide variety of
    applications which are similarly less needy of system resources…

if neither of those wind your watch, there are LOTS of others, see
http://tinyurl.com/ylf8zq9 which i wrote a few years ago (using a
different nom de plume)…some of those might have gone away and other
replaced them…but, there are lots of distro with less needs than
openSUSE…

  1. if you simply must have the best distro, then stick with openSUSE but
    go for LXDE or Xfce and i would suggest you install 11.4 rather than
    12.1, and forget about fancy spinning cubes and see though panes (unless
    you enjoy waiting for my machine to catch up)

on the other hand, it is your time you are wasting (week and a half!)
trying to stuff 10 pounds of potatoes into a 5 pound sack.


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

Hey, thanks for the fast reply.

It’s kind of odd that you say that I should not be able to run suse due to my “old school” box. I tried suse 12.1 with gnome and KDE and both ran fine, though gnome was a little faster than kde. And of course, in KDE, I absolutely needed to remove a few fancy animations in order to have “decent” performance. But it’s not that bad, if I compare to what I have with Xp fundamentals for legacy pcs (dual boot).

Basically, if I understand correctly, there is nothing that can be done in 12.1 with the specs I have ?

On 12/17/2011 11:16 PM, G Couture wrote:
> if I understand correctly, there is nothing that can be done
> in 12.1 with the specs I have ?

no, that is not exactly what i said…

and, you probably noted i didn’t say anything about how to get your
video to work better…because i’ve no clue on that…the last nvidia i
had “just worked” [but it wasn’t the same as your] and i have no idea to
prod your TNT into doing more than you can coax out of it–except that
11.4’s kernel is a good bit different from 12.1’s…

on the other hand 12.1 has SAX3 which might help with the video setup
but that is absolutely a work in progress, see the thread “sax3 testers
needed !!” http://forums.opensuse.org/showthread.php?t=464419

there are others here who will recommend you stick with 12.1 no matter
what…everyone here has their own opinion…i gave you mine: with
your hardware a given i recommend 11.4 and LXDE or Xfce or a lighter
distro…

and, the lighter distro might get you an older kernel/xorg combo in
one of the lighter distros which will also run rings around your XP
benchmark and fit your TNT better–but, i don’t know that…

its a weekend, stick around for a day or two and see what the others
have to say…(i mean, you have 10 or so days and a headache invested
already…so, give it a few more days and opinions…)


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
openSUSE®, the “German Engineered Automobiles” of operating systems!

Your box specs have little to do with the problem you describe, so I wouldn’t get side-tracked with that discussion, but your video card and the legacy driver may the issue here.

You mentioned

But now the problem I have is that I cannot access to any settings at all when I start ‘‘nvidia-settings’’. I only have one option tab on the left. I tried to use another display manager and still, it doesn’t detect anything in the S-Video output. I tried a lot of different suggestions that I read but nothing seems to do it. Even reversing to the ‘‘nouveau’’ driver does not make a difference.

Are you running nvidia-settings as root? This can be done from a terminal with

kdesu nvidia-settings

Do you get presented with more options?

If your tv is connected before booting, does the S-Video output get detected?

This reference may be useful:
NVidiaProprietaryDriver - MythTV Official Wiki

G Couture wrote:

> I decided to post after a week and a half of reading and headache. I
> have installed the NVIDIA proprietary driver
> (NVIDIA-Linux-x86-71.86.15-pkg1.run) that I got from their website.
> Installed the '‘hardway’

Why the hard way?
Why not use the nvidia repository to install the driver?
Look at this:
http://members.quicknet.nl/c.maaskant/YastRepo.gif

Chris Maaskant

If required, it may be possible to construct a minimal /etc/X11/xorg.conf file, with the analogue SVIDEO output defined/enabled.

nVidia/TV-OUT - Wikibooks, open books for an open world

Why the hard way?
Why not use the nvidia repository to install the driver?
Look at this:
http://members.quicknet.nl/c.maaskant/YastRepo.gif

Chris Maaskant

OP’s choice I guess, and it will make no difference to the ‘nvidia-settings’ issue described. The OP is asking about enabling the S-Video output.

When starting nvidia-settings from root, I get “ERROR: NV-CONTROL extension not found on this Display.” … And NVIDIA X Server Settings gets loaded, but with only one tab on the left menu, being nvidia-settings configuration…

The tv is connected before booting, and no, the S-Video output does not even get detected

I noticed that there is no xorg.conf and that sax2 nor sax3 do the trick to build a file… Could that be the issue? Last time I tried to manually make a xorg.conf I ****ed everything up…

Am 17.12.2011 21:06, schrieb G Couture:
> (NVIDIA-Linux-x86-71.86.15-pkg1.run) that I got from their website.
> Installed the ‘‘hardway’’ … Blacklisted ‘‘nouveau’’ driver, added
> -nomodeset- to boot, changed the kms value in sys/config, ''modprobed it
> then ‘‘mkinitrd’’. So far, so good.
Looking into the readme of that driver I see
Last Updated: $Date: 2009/07/02 $
I would guess that is simply too old to expect it to work with modern X
servers and modern kernels.
If it is an option for you to switch to a conservative linux distro for
that machine I would recommend Scientific Linux 6 (based on RHEL 6).
It still has the 71.86.14 driver as rpm in the atrpm repository and I
would guess you will have more luck with it.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
nVidia ION | 3GB Ram

Thank you for the suggestion. But say I want to stick to opensuse, would there be a way to possibly make that old hardware work ? Perhaps with the “nouveau” driver ? Would that be less of a compatibility issue ?

Am 18.12.2011 17:36, schrieb G Couture:
>
> Thank you for the suggestion. But say I want to stick to opensuse,
> would there be a way to possibly make that old hardware work ?
> Perhaps with the “nouveau” driver ? Would that be less of a
> compatibility issue ?
>
I do not have your hardware, I recently tried 12.1 on an old machine
where I had 11.3 running before without trouble. It has an old GeForce 2
card which uses the 96.x driver (which is still supported by the nvidia
repo for openSUSE) I had nothing but trouble with the proprietary driver
and the nouveau driver, none works well, I found it too tedious to spend
to much time with that and gave up to install 11.4 or 12.1 on it.

The only alternative which I can think of is to go back to an older
openSUSE version supported by evergreen for long term support (at the
moment 11.1 and 11.2 are supported by that).


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
nVidia ION | 3GB Ram

With older hardware, does the ‘nv’ driver not work ?

I noticed that there is no xorg.conf and that sax2 nor sax3 do the trick to build a file… Could that be the issue? Last time I tried to manually make a xorg.conf I ****ed everything up…

The sax2 utility has been deprecated for the last few versions now, and sax3 does not yet handle dual screen output, and is designed for the new config files located in ‘/etc/X11/xorg.conf.d/’. There is a risk when creating/editing Xorg config files, that will result in unintended effects, or the X-server not starting. Sometimes, it is a matter of experimentation, so one needs to be confident about what they are doing, make a backup of any working xorg.conf, and know how to remove the file if need be (from runlevel 3). I don’t really want to explain those things further, so if you’re not up to that, I’d simply stick with openSUSE 11.4, and update your computer, or at least graphics card when you can. If you think you can cope with this, then try using the ‘nvidia-xconfig’ utility to generate a working xorg.conf file first. From there, an editor may be required to hand-edit options to assist with the s-video output, but it is in the realm of trial and error. It depends on how much you want to pursue this requirement, with your old graphics card.

It’s a P3 800MHZ overclocked to 900 with 512 megs of Ram with :

00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 23)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 11)
00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management (rev 30)
00:09.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
00:11.0 Multimedia audio controller: Yamaha Corporation YMF-744B [DS-1S Audio Controller] (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

If you say 11.3 worked well, I guess I’ll try going for that distribution. I’ll keep you posted on how everything goes once I’m finished installing (hours of fun).

One last thing though, I noticed that I can’t enable dual display on Xp fundamentals for legacy pc either. Perhaps the nvidia legacy drivers for xp don’t support twinview. Or could it simply be that my board somehow does not support that function ? Could that be possible ?

Am 18.12.2011 20:16, schrieb G Couture:
>
> If you say 11.3 worked well, I guess I’ll try going for that
> distribution. I’ll keep you posted on how everything goes once I’m
> finished installing (hours of fun)
>
11.3 worked well on my old sandbox machine for playing around which has
of course a different hardware than yours and another difference the
graphics card is slightly newer than yours.
I guess you need to find out which was the last version which worked
with the 71.x nvidia drivers (I simply do not remember) and then see if
it is still supported (by the Evergreen project).

Beside that of course deano ferrari gives you excellent tips which may
even lead with a new openSUSE version to a success.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
nVidia ION | 3GB Ram

How do you run nvidia-xconfig to generate a xorg.conf file ? I tried, but it seems to be missing and nowhere to be found. I do have the ‘/etc/X11/xorg.conf.d/’ folder thought, but here’s what 50-screen.conf, 50-device.conf and 50-monitor.conf look like… I also have a xorg.conf.install file located in ‘/etc/X11’ … Perhaps this can give you guys a few hints… Thanks again.

Having multiple “Screen” sections is known to be problematic. Make

sure you don’t have in use another one laying around e.g. in another

xorg.conf.d file or even a generic xorg.conf file. More details can

be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.

#Section “Screen”

Identifier “Default Screen”

Device “Default Device”

## Doesn’t help for radeon/radeonhd drivers; use magic in

## 50-device.conf instead

Monitor “Default Monitor”

#EndSection

Having multiple “Device” sections is known to be problematic. Make

sure you don’t have in use another one laying around e.g. in another

xorg.conf.d file or even a generic xorg.conf file. More details can

be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.

#Section “Device”

Identifier “Default Device”

#Driver “radeon”

## Required magic for radeon/radeonhd drivers; output name

## (here: “DVI-0”) can be figured out via ‘xrandr -q’

#Option “monitor-DVI-0” “Default Monitor”

#EndSection

Having multiple “Monitor” sections is known to be problematic. Make

sure you don’t have in use another one laying around e.g. in another

xorg.conf.d file or even a generic xorg.conf file. More details can

be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.

#Section “Monitor”

Identifier “Default Monitor”

## If your monitor doesn’t support DDC you may override the

## defaults here

#HorizSync 28-85

#VertRefresh 50-100

## Add your mode lines here, use e.g the cvt tool

#EndSection

Just run it as root from a terminal. It checks for the existence of /etc/X11/xorg.conf first, and creates if necessary. You can use options too. For example

nvidia-xconfig --twinview

Read these references:
man nvidia-xconfig
https://wiki.archlinux.org/index.php/NVIDIA

Here’s what it outputs

If ‘nvidia-xconfig’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf nvidia-xconfig