cannot configure an HP deskjet on usb in 13.2

I have an HP 6122 simple deskjet printer that I had running in 13.2 before. Then because of nvidia problems I did a fresh install. Yast2 can not discover the printer.

hp-set up does find the printer but then hangs in step 2 in the gui version

I recently added the repository and got new hplib files from there but that did not do the job

> hp-setup -i --auto 004:002

give me: setting up device: hp:/usb/deskjet_6122?serial=MY3AN2B3G766

but does not go any further.

any help would be appreciated.


Go to and enter hplip; when this shows up, go to 13.2 Unsupported versions and select Printing. Install this version (3.15.4) and try again.

If you still have problems after following John’s advice, run (as user)


and examine the output for reported problems. If necessary, you can upload to
and post the link that it generates here.

When I installed the …/Printing/OpenSUSE_13.2, the version of hplip I got was 3.15.4 and this did not do the job but then I tried hp-doctor which looked like it would do the job but did not - see next reply

I ran hp-doctor and got told there were many dependencies missing and I let hp-doctor run zypper correct that. Then:

Bus 004 Device 002: ID 03f0:3404 Hewlett-Packard DeskJet 6122

> hp-setup -i --auto 004:002

Setting up device: hp:/usb/deskjet_6122?serial=MY3AN2B3G766
---------------------| PRINT QUEUE SETUP |

Using queue name: deskjet_6122
Locating PPD file… Please wait.
error: No PPD found for model deskjet_6122 using old algorithm.
error: Unable to find an appropriate PPD file.
Please enter the full filesystem path to the PPD file to use (q=quit) :
Description for the file: HP Deskjet 6122, hpcups 3.15.4
Adding print queue to CUPS:
Device URI: hp:/usb/deskjet_6122?serial=MY3AN2B3G766
Queue name: deskjet_6122
PPD file: /usr/share/cups/model/manufacturer-PPDs/hplip/hp-deskjet_6122.ppd.gz
Information: deskjet 6122 Device (Automatically setup by HPLIP)
error: Printer queue setup failed. Error : successful-ok-ignored-or-substituted-attributes

I also tried running hp-setup again with the PPD:

but that did not help either.

I am willing to try a few more things, perhaps, even going back to the 3.14.6
Also, I did not run hp-setup as root but as myself.

Ok, open CUPS at localhost:631/, select Printers and then your printer and then Administration>Modify printer. You will be asked for the root password. Go through several options (accepting them) until you get to the PPD options - it will probably take ages to scroll through the choices until you reach the 6122 but try each of the PPDs.

In other words, I am saying: Don’t use hp-setup. This may not work but it did for me after neither YaST nor hp-setup were able to solve the problem when I purchased a new HP printer.

There is also a pair of gutenprint PPDs if that does not work.

I am willing to try a few more things, perhaps, even going back to the 3.14.6

Yes, that might be worth a shot.

FWIW, I’m seeing other failed reports online with those using 3.15.4

Try configuring in GUI mode

su -c hp-setup

A new version of CUPS came through from the openSUSE Printing repository so I updated my hplip installs to 3.15.4

tried the gui version and when it could not find a PPD it asked me to browse and pick one. Clicked the browse button and goot

error: No appropriate print PPD file found for model deskjet_6122
klauncher(6155) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
Segmentation fault

> ps aux | grep dbus

gives me this so it looks like dbus is running

message+ 838 0.0 0.0 33136 4492 ? Ss 10:56 0:01 /bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
ken 1717 0.0 0.0 14184 1724 ? S 11:00 0:00 /usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/ssh-agent /usr/bin/gpg-agent --sh --daemon --keep-display --write-env-file /home/ken/.gnupg/ /etc/X11/xinit/xinitrc
ken 1718 0.0 0.0 32608 2816 ? Ss 11:00 0:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
root 2162 0.0 0.0 14188 1864 ? S 11:01 0:00 /bin/dbus-launch --autolaunch 4ed603cd18304c8d9216b69334cdeb3a --binary-syntax --close-stderr
root 2163 0.0 0.0 32096 300 ? Ss 11:01 0:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
ken 6169 0.0 0.0 10524 1612 pts/11 S+ 11:53 0:00 grep dbus

searching with Google brings me to a lot of problems like this but I have never seen a solution.


When you get the (empty) list of PPDs in CUPS, choose Another Make/Manufacturer and on the next page Choose file. The PPDs on my system are:


Try one of these and see whether that helps.

sorry, my previous message was a bit misleading. While I did update CUPS, I tried the installation with hp-set in gui mode. It bombs when I click on the widget button to select a PPD file.

Just tried CUPS again and it could not even find the printer.

At this point I am thinking of just hooking the printer up to a different computer or trying the tumbleweed release. The latter is pretty drastic just to fix a printer.

Check if this behaves any differently for you

kdesu hp-setup

On 2015-06-10 16:36, kpdere2968 wrote:
> or trying the tumbleweed release. The latter is
> pretty drastic just to fix a printer.

You can install it in a small virtual machine, to try. As it connects
via usb, it should work, if the issue is solved with tumbleweed.

With a virtual machine you don’t have to replace your installation.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))