Cannot config DNS using YAST

When I try to setup DNS via YAST in 11 I get as far as the zone setup.

I can add a New Zone, click the Editor but when I try to move off the Basics Tab I get the following error:

terminate called after throwing an instance of ‘std::logic_error’
what(): basic_string::_S_construct NULL not valid
YaST got signal 6 at YCP file dns-server/dialog-masterzone.ycp:282
/sbin/yast2: line 421: 5723 Aborted $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

I tried to uninstall and reinstall DNS but get same error.

Any ideas? There are a few more tabs in 11 than 10.3 so not sure if I am missing something.

Thanks for help!

This is just a confirmation that another user experiences the exact same error and eventual crash. The problem is a bug with the “Zone Editor” window. Unfortunately, I cannot find or deduce any work-around other than breaking out a text editor.

I validated that some one else has already logged the bug and commented to confirm:

If you read this lesson you can start dns on yast

Configuring DNS and DHCP on Suse Linux Enterprise Server

I found a work-around to the Yast DNS Server configuration bug. The bug occurs when the Yast tools tries to pass a TSIG key array to the Zone Editor panel. If there are no TSIG keys, the array is null and causes a crash. Thus, to work-around this issue, simple create at last one TSIG key before attempting to edit zones. Once a TSIG key exist, all tool features work fine.


Thanks for the help, worked perfectly!