Cannot compile VMware WS 12.5.2 on latest Tumbleweed build


I’m running into errors trying to compile VMware WS 12.5.2 on TW with kernel 4.9.10-1-default. So far non of the suggestions are working. Here’s one example output

marty@openSUSE:/tmp/vmware/source/vmnet-only> sudo make
Using kernel build system.
make -C /lib/modules/4.9.10-1-default/build/include/… SUBDIRS=$PWD SRCROOT=$PWD/.
make[1]: Entering directory ‘/usr/src/linux-4.9.10-1-obj/x86_64/default’
CC [M] /tmp/vmware/source/vmnet-only/userif.o
/tmp/vmware/source/vmnet-only/userif.c: In function ‘UserifLockPage’:
/tmp/vmware/source/vmnet-only/userif.c:117:43: error: passing argument 5 of ‘get_user_pages’ from incompatible pointer type -Werror=incompatible-pointer-types]
retval = get_user_pages(addr, 1, 1, 0, &page, NULL);
In file included from /usr/src/linux-4.9.10-1/include/linux/highmem.h:7:0,
from /tmp/vmware/source/vmnet-only/userif.c:26:
/usr/src/linux-4.9.10-1/include/linux/mm.h:1280:6: note: expected ‘struct vm_area_struct **’ but argument is of type ‘struct page **’
long get_user_pages(unsigned long start, unsigned long nr_pages,
/tmp/vmware/source/vmnet-only/userif.c:117:13: error: too many arguments to function ‘get_user_pages’
retval = get_user_pages(addr, 1, 1, 0, &page, NULL);
In file included from /usr/src/linux-4.9.10-1/include/linux/highmem.h:7:0,
from /tmp/vmware/source/vmnet-only/userif.c:26:
/usr/src/linux-4.9.10-1/include/linux/mm.h:1280:6: note: declared here
long get_user_pages(unsigned long start, unsigned long nr_pages,
cc1: some warnings being treated as errors
make[4]: *** [/usr/src/linux-4.9.10-1/scripts/ /tmp/vmware/source/vmnet-only/userif.o] Error 1
make[3]: *** [/usr/src/linux-4.9.10-1/Makefile:1500: module/tmp/vmware/source/vmnet-only] Error 2
make[2]: *** [Makefile:150: sub-make] Error 2
make[1]: *** [Makefile:24: __sub-make] Error 2
make[1]: Leaving directory ‘/usr/src/linux-4.9.10-1-obj/x86_64/default’
make: *** [Makefile:120: vmnet.ko] Error 2

If anyone has installed VMware WS on TW using kernel 4.9.10 (or perhaps an earlier 4.9 I appreciate ideas on how make WS work.


Thanks for the reply. I have tried the first two links (they are the same). That patch did not work for me and I have emailed the author with the output from the script. Have not received a reply yet but hope to as that seems to be the latest - just a month ago or so.

I do have a license for the Windows version and I have Windows 10 & Windows Server 2016 in a triple boot with openSUSE but would much prefer to install on openSUSE Linux. It works perfectly on Leap but since I’ve upgraded to TW I’d rather stay with it for some time.

If you can do it,
It makes a lot more sense to run LEAP as your multi-boot OS and then TW in a Guest.
Be aware that as long as TW is your HostOS, you’ll likely continue to run into these kinds of problems.


Yes I absolutely realize that. So I upgraded Leap to TW directly using zypper viz

Step 1: First of all make a backup of the current Leap repositories by creating a new folder “old” and moving the Leap repos into that folder. You will have to run all the commands as root user

su -
mkdir /etc/zypp/repos.d/old
mv /etc/zypp/repos.d/*.repo /etc/zypp/repos.d/leap

Step 2: Add the new Official repositories, Tumbleweed repositories.

zypper ar -f -c repo-oss
zypper ar -f -c repo-non-oss
zypper ar -f -c repo-debug
zypper ar -f -c repo-update

Step 3: Check the installed repositories by running the command:

zypper lr -u

This will list all the available repositories that you have added to your system.

Step 4: Refresh the repositories accept the new gpg keys.

zypper --gpg-auto-import-keys ref

Step 5: Upgrade the system:

sudo zypper dup

Now I also mkdir /etc/zypp/repos.d/tumbleweed and copy all the TW to this subdir. Now if I wish I can rm /etc/zypp/repos.d/*.repo and then use zypper to add all the leap repos and perform a rollback to Leap. I haven’t tried this yet because I would rather see some of the openSUSE wizards get around to compiling Workstation on the 4.10 kernel. Indeed since I am tripling booting with Windows 10 Insider and Windows Server 2016 I can and will install Workstation for Windows on Windows 10 and still have my Hyper-V machines on Windows Server. I two 1TB drives avaialble to install Windows and Linux VMs.

I just love openSUSE. And I have lots of fun