cannot compile virtualbox kernel

Hi all,

I installed virtualbox 3.1.3 from sun, and I tried virtualbox ose from repos.

I am getting the same error, that I need to recompile the kernel for virtualbox.

So I try:

sudo /etc/init.d/vboxdrv setup

But the recompile fails.

I check the log and this is what it says:

Makefile:152: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.

Any ideas?



you need kernel-source and the kernel-flavour-devel

flavour = whatever kernel you have: default, pae, desktop

also required
make, gcc, linux-kernel-headers,

You also need package kernel-syms to compile apart from the above ones…



Not correct
I don’t have it

kernel-syms will drag in stuff you really don’t need

Hey Caf,

Thanks a million,

That did it, without the syms.

Thanks again,


:wink: That’s good

Bit late now but
Virtual Box (Sun Version) Install HowTo - openSUSE Forums

Thanks to caf4926 I was able to install a virtual machine in my 64bit systemrotfl!! The first time! There were never problems with this on my 32bit systems. But since a year I was trying to run it under the other one. I only got messages about missing vboxdrivers (which were installed, but could not be found).
The only thing I am a bit puzzeled about is, that I could not find the “kernel-flavour-devel” in YAST.
So, after deep thinking about the consequences of installing rubbish on my working-system (about one minute), I decided to install the “virtualbox-ose-kmp-default” (my kernel version). So I made a data-backup and installed the kernel.
Doining the rest in console as root…and what happened? The virtual box started and let me know, that everything was right and I could start the machine (I still have to install one).
So thanks again:)!

the kernel-flavour
refers to which kernel you have installed
Eg: default, desktop, pae

so if you were using kernel-default

you would add kernel-default-devel

But you figured that - right?:wink:

Yes, my system uses the “default” kernel, so I installed this one. As I said, it works fine. I just finished setting up winXP (sorry, but I have to use it for business;)). Works good, even with 3D, USB, DVD and SOUNDlol!.
For interest, though it runs:
Were can I find the “kernel-default-devel”? Is this a short form for something longer? When I type this in “software-installation” under YAST, I only get the message, that there can nothing be found…:. Do I have to set up another repository?

su terminal

zypper in kernel-default-devel

OK, I have done it. Thanks caf! This installed it.
And thank goodness, everything workes further more;).
Do I have to uninstall the “virtualbox kernel” or can I leave it, where it is?

Hang on to it. You’ll need it next time the kernel is updated. It will allow only the delta RPM to be downloaded to apply to it, saving you some download.

OK. Then it will get a warm and confortable place on my HDD:).
Thanks so far.