Cannot come out of suspend or screen saver

Not sure if this is the correct place to post this as I’m not sure if it’s KDE, system or what that is causing this.

This morning I did a clean install of 11.1 with KDE and updated to 4.2.4. I also have the latest kernel version that was just released. It was installed automatically by tp_smapi which is required for Thinkpads to control battery charge thresholds and the disk park accelerometer.

Anyway, now when my screen saver (just blank screen) activates or when I do a suspend to ram/disk I cannot come back out of it. I get a error saying screen was locked by {username} and cannot be unlocked. The button are all greyed out. The only way out is to ctrl / alt / backspace and then login in again.

Any ideas why this is happening. Havien’t a clue as to where to start looking. I have the screen saver set to NOT require a password.

Don’t know how to solve the problem but have you tried allowing a password to see if that solves the problem temporarily?

Yep, tried with and without passwords enabled. I basically have everything else running fine now apart from this which is a major problem as it’s a laptop and frequently gets suspended.

Are there any commands I can issue to list the logs that would be generated at the time of coming out of suspend or screen saver?


I probably have the same, a lot of web articles are aimed to solve simple “uncle computer problems” related to screen saver, but what I have is wayyyy deeper than this,
I hope that by posting this, I’ll get either a fix or a tip on how to get more info on the problem…

My screesaver activates and sometimes, can be unlocked, but sometimes (I think when running for a long time) cannot be unlocked, in which case I dont even get the “password” popup and the screen saver is not moving anymore
I cannot CTRL-AFT-F1 either (to get a tty)

What I did…

I did play with
to force one screen saver or to disable it completely
…no luck

As I’m writing this, the laptop is hung !
but I can still ssh to it…
This is what “top” gives me:
top - 21:54:32 up 8:06, 13 users, load average: 1.00, 1.05, 1.08
Tasks: 160 total, 3 running, 157 sleeping, 0 stopped, 0 zombie
Cpu0 : 0.3%us, 0.0%sy, 0.0%ni, 98.3%id, 1.3%wa, 0.0%hi, 0.0%si, 0.0%st
Cpu1 : 0.0%us,100.0%sy, 0.0%ni, 0.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 4042696k total, 4018380k used, 24316k free, 91592k buffers
Swap: 0k total, 0k used, 0k free, 3403516k cached

10416 pmichel 19 39 261m 22m 3936 R 100 0.6 398:16.07 1 238m 80 33m 235 0 - gleidescope
1 root 0 20 1064 388 324 S 0 0.0 0:01.04 1 676 812 240 10 0 - init
2 root -5 15 0 0 0 S 0 0.0 0:00.00 0 0 0 0 0 0 kthreadd kthreadd
3 root -5 RT 0 0 0 S 0 0.0 0:00.00 0 0 0 0 0 0 migration migration/0
4 root -5 15 0 0 0 S 0 0.0 0:04.86 0 0 0 0 0 0 ksoftirqd ksoftirqd/0

dam I cannot get it to show properly !
it shows that
gleidescope (THE screen saver)
uses 101% cpu time
unfortunately, it doesn’t show WCHAN (wait channel) it shows “-”

I tried to gdb the dam thing:

gdb /usr/lib64/xscreensaver/gleidescope 10416

GNU gdb (GDB; openSUSE 11.1)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying”
and “show warranty” for details.
This GDB was configured as “x86_64-suse-linux”.
For bug reporting instructions, please see:
(no debugging symbols found)
Attaching to program: /usr/lib64/xscreensaver/gleidescope, process 10416

But it does not stop the process
which tells me that the process is jammed in an OS call…
I will try to lower it’s priority…but I doubt it will work

This happens with different screen savers (KEuphoria, flurry…probably others)
I thought that KEuphoria was ok, so I forced as default screensaver, but eventually it hung on me

Any ideas ?
is there a way to ask Kde to start the screen savers via Strace to see which is the last OS call?


If I’m correct, you had 11.1 installed previous to this? Did suspend work OK then?

I don’t use any sceensaver - nothing!

Also. If your suspend worked with your previous install, I would experiment by rolling the recent kernel back one. (reboot needed of course). See how it is then.

Not quite !
I had suse 10.3 previously,
running incredibly fine…
and I recently switched to 11.1 x86_64 on my 2 PCs

I’m sure I’m not the only one with the problem, so I’d rater find the cause or fix it !

Additional notes:
I run suse 11.1 on 2 machines, and only the laptop hangs
I did not see the problem manifest itself from a suspend…only screen savers do that

Laptop info:
I use dual screen,
It’s a Dell D630
with a crappy Intel 965 GM video card, 3D support activated
4 Gig ram
Core 2 duo
Running Kde 3 (I tried Kde4, it looks nice, but crashes a lot with dual screen and vmware…kinda unproductive)

For now, I made a cron job that will kill the screen saver if it mis-behaves

The above quote was aimed at @suse_tpx60s

Sorry @pmichelmp3
But re; your issue. I would just recommend not using screensaver at all. Disable it all completely.

Yes when I have first installed 11.1, I used Gnome and suspend to disk and ram both worked well, as did the screen saver (blank screen). It’s only under KDE that my suspend to disk and ram don’t work properly and I get an error when trying to come out of screen saver or suspend. I’ll have to photograph the screen and post it as I can’t do a screen capture.

I discovered a few things though. While in the KDE desktop I cannot initiate a suspend by using my FN+F4 or F12 buttons, nor does it suspend when I close the lid. But when I ctrl, alt. backspace (I have to do it twice) to clear the locked screen and return me the text screen then suddenly my suspend to disk and ram buttons work. There is definitely something starnge with the way KDE handles this because in Gnome there were no problems.

But have the settings in power management to suspend on lid close? Obviously, what a silly question.
You don’t still have any powersave packages installed do you? They need to go!

YESSSS!!! I fixed it. thanks to mscham’s solution posted here.

It turns out that it’s a problem with having the fingerprint reader enabled for login authentication. Once I disabled it it solved my problem with not being able login after coming out of screensaver or suspend.

Also, for some reason my suspend to ram and disk function keys seem to be working now. I have no idea what I did or why they are working now but they started working this morning. I know it’s the worst scenario not knowing what fixed it or why it started working - sorry. All I was doing was getting Thunderbird installed and set up with my mail accounts etc, OpenOffice configured and a few other apps to that I will require for my daily needs. I was messing with trying to get my HDAPS working but don’t think anything I did was related to the suspend stuff. Anyway it’s working so I’m happy.

caf4926, what do you mean that I don’t require any of the powersave packages? I have Kpowersave installed with I use to set the various power profiles, screen brightnesses, auto suspend etc. It seems to work quite well and I prefer it to the battery monitor widget which isn’t as configurable.

kpowersave and powersave packages are for kde3/gnome
I have none installed. If I do I get problems too. See my shot of powersave search](

Yes, I figured Kpowersave was for KDE3 but it seems to work OK well at least I haven’t spotted any problems yet. It’s strange that it hasn’t been updated for KDE4 as it’s such a good app. The KDE4 battery monitor widget is nowhere near as configurable or functional for me.

I can’t say I agree with your findings about Powerdevil, but I’m not going to argue about it.
At least you have your suspend sorted.

It seems I got a litt;le confused and didn’t really understand Powerdevil. I am now taking a closer look at it.