cannot close windows after enabling compiz

Hi again,

I succeeded to enable compiz on Gnome (on the “hard way”), but since I have problems with certain windows.

  1. Firefox is appearing only in a small window in the upper left corner, and I am unable to maximize it nor through View/full screen, neither with Alt+F10.
    No upper toolbar for closing window.

  2. Yast. I can open it, use it, but I lost the upper toolbar allowing to minimize/maximize and close it (right upper corner). Same with Control Center, or Terminal. The only thing I am able is moving them around with alt+left click. No response to Alt+F4

  3. not related (maybe), I’ve tried to enable Cube and it ask for enabling XGL, but nothing happens when I click on enable.

thanks in advance

Do you have emerald installed?

open a terminal and provide the output of

rpm -qa --last "*compiz*"

Take Care,


No, I don’t have emerald installed. and when I am unabling desktop effects everything going back to normal.

But right now I have a problem to install anything as I get a notice that one of my partitions /dev/sda7 (home) is almost full.

Since I am a new user, and need Windows XP for work, I dual booting, and the place for Opensuse 11.1 is considerably smaller. I have enough disk place, I am just not sure if i can adventure and reduce more windows and add to Opensuse and how to doo it.

this is what I have:

dev/sda 239.89GB

dev/sda1 190.43GB HPFS/NTFS /windows/C
dev/sda2 29.30GB HPFS/NTFS /windows/D
dev/sda3 13.15GB Extended
dev/sda5 2.01GB Linux swap
dev/sda6 5.19GB Linux native EXT3 /
dev/sda7 5.95GB Linux native EXT3 /home