Cannot Change Screen Resolution in 11.0

I am having a problem with changing my screen resolution in Opensuse 11.0. Using YAST, I can change the resolution to whatever I want. I run the test. The test works fine. I then save the configuration but the resolution does not change. It is always fixed at 800x600. I then reboot and the resolution stays at 800x600 even though YAST thinks it is 1024x768 for example. The weird thing is that when I boot in fail safe mode, the resolution is always fixed at 1024x768 regardless of what I change in YAST. Any ideas?

I am using an Nvidia GeForce 6100 nForce 405 video card and I have installed the latest Nvidia drivers from the Nvidia repository.

Have you tried running nvidia-settings and changing it there?

When I run nvidia-settings, I get the following error:

You do not appear to be using the NVIDIA X driver. Please edit your C configuration file (just run ‘nvidia-xconfig’ as root) and restart the X server.

So I ran nvidia-xconfig. Rebooted. Tried to run nvidia-settings and got the same error.

Any ideas?

OK. I have made some progress on this. I found another thread in this forum at How Do I Configure My Nvidia Drivers After The Driver Installation? - openSUSE Forums. I removed all of the drivers that were installed via YAST2. I downloaded the driver from the Nvidia website and manually installed it following the directions in the thread.

Now nvidia-settings works! I am able to change the screen resolutions and everything works perfectly under root. However, in my normal user login profile the screen still defaults to 800x600. I am able to change it via nvidia-settings, but when I reboot the screen goes back to 800x600. Seems like I am almost there. Any ideas?

I believe you might have to change it as well under the DE that your using. kcontrol has a display resolution under hardware as well as the gnome-control-center. What are the options listed there?

in nvidia-settings did you use ‘apply’ or ‘save to X configuration file’?

Yes. I had clicked on apply and then on Save to X Configuration file.

I got a sort of weird result from looking at the Control Center. I am using Gnome. First of all, using nvidia-settings, I changed the resolution to 1024x768, 24-bit color depth, 60 Hz refresh. Clicked apply and the saved the configuration file. Everything so far so good. Then as suggested, I went to the Control Center and clicked on the Screen Resolution button. It shows that the monitor is unknown. The only available resolution is 1024x768 and the only refresh rates are 50, 52, 53, and 54. So I just clicked apply and then clicked on close.

Then I rebooted and low and behold for some reason it now remembered my settings and kept the 1024x768 resolution instead of going back to the 800x600. Since it was so weird, I have no idea why that worked. Nonetheless, it worked. Thanks for the help!