Cannot Change Permissions on Directory


I have recently installed a new hard drive on my OpenSuse. It used to be an external drive. It is FAT formated, and I don’t want to change that, since it is kind of full.

After I installed the drive and made the necessary changes to etc/fstab, I have rwx permissions on all directories (as wanted) except one (local/Music).

I read somewhere that permissions cannot be changed with chmod on FAT partitions, since they don’t support unix permissions…

Taking that into consideration, I cannot understand how one directory can have distinct permissions than the others.

How can I change the permissions on that directory?

Thank you,

What is the permission showing for that directory?

quite strange…

and here is the fstab entry
/dev/disk/by-id/scsi-SATA_HDS725050KLAT80_KRVA05ZAJZ9THF-part1 /local vfat users,gid=users,umask=0002,utf8=true 0 0.,

but as I said I only have problems with this one directory…

That shows a read-only permission. FAT has that capability (to make a file/directory read-only). I think the vfat driver is actually supporting that bit. (Need to read up on that or someone else can clarify).
Just change it and see if it survives across unmount/mount.

somehow I was kind of confused when I tried it yesterday and used the wrong octal permissions. Meaning: while I wanted to give rwxrwxrwx (777) I gave 700. Even though i do not exactly understand why changing permissions to 700 is not permitted, changing them to 777 worked…so mission accomplished…

thank you!

That means the read-only flag on FAT file system is respected in the vfat implementation.