Cannot change Login theme - permanent problem.

Another annoying problem.
I want to set my login screen to “Design Mode” and to look great, but even if set to use “Design” in System Settings, it just uses the default prompt that looks painful to the eye, knowing that I have Compiz Fusion and themes installed.

I’ve already rebuild the .kde4 folder (running KDE 4.2.1 currently) - obviously that didn’t help.



Am I really the only one having that freakin´ issue? :smiley:


No you’re not… I’m having the same problem for months, and I don’t knot what to do…

Good to know - I wonder if this is an issue that is possible to get rid of with an easy fix…


Well try to start /etc/sysconfig editor from yast and find kdm login manager theme entry. Change it to i.e oxygen and restart to see if your kdm theme is changed.

Thanks Mate, it CHANGED. Sadly, “oxygen” is not the Oxygen-Design I wanted to use… otherwise it would be perfect.


you can also go into /etc/sysconfig/displaymanager as root and change the line DISPLAYMANAGER_KDM_THEME=“to what you want” if your theme is installed

Yeah… and “what I want” is the oxygen theme. just go to system settings, login manager → “oxygen theme”. There you’ll see the prview with a black background (curly) as well as some boxes to select the user to login on the picture.

THAT’S what i want… :wink:


WTF? Gotta get that **** solved somehow… :frowning:


KDE4 has so many critical bugs, some of them are almost one year old… Something is very wrong there in KDE team.
I mean critical bugs…
… and people use to say that bugs on Linux (I mean KDE4 to be precise) are mostly fixed in few hours… This is a MYTH! It take almost a year… and then again pray for it to be fixed…

In kde 4.3 beta you can change the login theme by opening
configure desktop > advanced > login manager in the themes tab you can download new themes.
the files are located at /usr/share/kde4/apps/kdm/themes