cannot boot with degraded software raid

some background…
I am an IT guy trying to help out a friend. This linux setup belongs to his church. So they have no funds for IT help. The original IT person that setup system is no longer available. So here’s the problem. One of the hard drives of the RAID1 setup failed and the original machine is no longer availabe. All I have is one IDE hard drive from the RAID array. They have asked for my help which I have limited Linux experience but can follow directions well.

Currently, I have the hard drive in a USB enclosure connected to a Dell system I have. I have unplugged all the original Dell system hard drives. It looks like the linux system is 64-bit so this is the only system I have to connect it to. Downside is that has no IDE controllers, hence why it is in a USB enclosure. I can choose to boot to it. When I do, it gets stuck booting up.

<tail of boot process>

Loading raid1
md: raid1 personality registered for level 1
Loading dm-mod
device-mapper: 4.5.0-ioctl (2005-10-04) initialised:
Loading dm-snapshot
Waiting for /dev/mapper/control to appear: ok
Loading reiserfs
md: md0 stopped.
mdadm: no devices found for /dev/md0
md: md1 stopped.
mdadm: no devices found for /dev/md1
Unable to find volume group “rootvg”
resume device /dev/rootvg/swap not found (ignoring)
md: md0 stopped.
mdadm: no devices found for /dev/md0
md: md1 stopped.
mdadm: no devices found for /dev/md1
Waiting for device /dev/rootvg/root to appear:…not found – exiting to /bin/sh
$ _

It then hangs here until I do a hard shutdown.

I tried booting to Live 64-bit dvd and went to Rescue System.

From there I ran ‘cat /proc/mdstat’.


Personalities : [raid1]
md1 : active raid1 sda2[0]
292929088 blocks [2/1] [U_]

md127 : active raid1 sda1[0]
104320 blocks [2/1] [U_]

unused devices: <none>

All I want to be able to do is get a copy of the user data for my friend. This linux installation will no longer needs to exist after that.

Thanks in advance for your assistance.

Why not just replace the failed drive and rebuild the array?

Anyway, you could just download a linux live CD and boot from that,
there is no need to boot from the busted system drive.

Once the system has started, plug in your usb connected drive and an
icon should appear on the desktop, browse the drive and get the data

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 0:00, 2 users, load average: 0.05, 0.07, 0.07
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

I just tried a Live CD and the external HD did not show up on the Desktop. Although I could see it when I did ‘fdisk -l’.

I tried to manually mount the device and I got this error.

mount: unknown filesystem type ‘linux_raid_member’

Can you provide the output from fdisk -l :slight_smile:

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 11:46, 2 users, load average: 0.08, 0.62, 1.25
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Output from fdisk -l

Disk /dev/sda: 300.0 GB, 300069052416 bytes
255 heads, 63 sectors/track, 36481 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xde0de808

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   fd  Linux raid autodetect
/dev/sda2              14       36481   292929210   fd  Linux raid autodetect

You’ll need to use the program mdadm to handle this RAID element. Have a read of the man page or look for a tutorial on the web showing you how to detect and mount a degraded array, then copy your data off it.

ok. so i was able to mount the raid array finally. I found this webpagethat helped my situation which was that this raid array also turned out to be ‘lvm2_member’. I didn’t have to do step 2 because lvm2 was already installed.

Now that it is mounted however, I can see the user data folders but don’t have permissions to access some of the folders. Is there a way to take ownership or get read permission of ‘ALL’ the home directory and subfolders/files so I can just copy the whole home directory to the another external hard drive. Then I can give them that external hard drive and they can decide what they need from that.

I’m soooo close. Thanks for your help so far.

Yes, just be root, and you can copy anything off the disk. You can adjust the ownerships of the copies later.

If you have booted from a live cd use the sudo command I think linux is
the password.

sudo -i

Else is you boot from a normal dvd/cd in Rescue mode you can login with
user root and then press enter when it ask for the password. From there
you can manually mount and browse.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 5 days 11:36, 3 users, load average: 0.63, 0.46, 0.23
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

That did it. I used the ‘sudo -i’ command as I was using the Live CD. I was able to get the data copied to another external hd.

Thanks for your help. I learned a lot as well.