Cannot boot to runlevel 3

As a result of problems with the display on a new installation of 11.3 on an Acer Aspire One, I thought I’d try a different OS. My wife and I share this netbook though because we travel often and want to keep our baggage to a minimum while still being able to work. I’d like to keep the OpenSuse 11.3 rather than risk messing up the Windows partition my wife uses. Wireless was fixed pretty early, but I’m having a host of other problems.
On to this problem. I cannot boot into runlevel 3 per the instructions on the SDB page. It hangs early at the lines:
Starting udev
Loading drivers, configuring devices

It often hangs on booting or shutting down in normal use (runlevel 5), so the problems may be related. Is there a log where I can track down these errors? I checked in /etc/udev, but didn’t find a log there.

Make sure there are no strange devices connected.

Did it happen during install from the DVD or when you boot the LiveCD?

It did happen during the install, but also during regular usage since then. I’m stumped with this netbook installation. I’ve had great success with Opensuse on other machines, even an old Via C3 powered Mini-itx board that works 24/7.

Have you tried any other Distributions?

/var/log/boot.msg ?

/var/log/boot.msg has a lot of interesting stuff, but I couldn’t find any errors in it. If it’s rewritten every time the OS boots, then it wouldn’t keep the errors recorded as I can’t read it when a boot fails and it locks up. It’s working enough to get by before taking it to the road/sky again tomorrow. It’s just a bit annoying to reboot until it gets past the udev stuff.
I tried the 11.2 live disc, and it even booted into KDE, which I hadn’t been able to do yet. I installed it, and it works significantly better. The display even works without tinkering. My wife says it’s “prettier” too. :slight_smile:
The hanging on startup and shutdown still persists though.

If you can boot to a liveCD immediately after such a problem, then the file will be there because the liveCD has not written to it.

Hash: SHA1

For acer one use the default kernel or the pae-kernel, if you use the
desktop it hang up with udev, I have the same problem with a client acer one


Microsoft Windows is like air conditioning
Stops working when you open a window.
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with SUSE -