Cannot boot opensuse leap 15.1 KDE Live from bootab;e USB-stick

Hello, guys,
I have a strange problem I’ve never seen before. I bought a new laptop ASUS TUF GAMING FX705GT I bought it without an OS with the idea to install Linux on it. But on Debian, Ubuntu and Ubuntu-based distros I ended up without a wi-fi adapter (not recognised, the adapter is RTL8821CE). So, I searched here in forum for problems with rtl8821ce and found a rpm package with a driver. I mage a bootable USB drive of opensuse leap 15.1 KDE Live in order to trst if the live distro will find my wifi or not. But after I rebooted I found myself in a console window. I made a photo with my phone

Can anybody tell me what is this and how to fix it, please.

The laptop specs are
Processor: AMD Ryzen 7 3750
Video: nVidia GTX1650
SSD 128 GB + HDD 1 TB

At the time of writing this I installed Win10 64bit to just make it work

It looks as if it does not like your nvidia graphics card.

Maybe try the Tumbleweed live KDE image. That uses a newer kernel. Or perhaps try the live Leap 15.2 (still at alpha testing). You can download from It also has a newer kernel (similar kernel to Tumbleweed).

Ok, thanks, I’ll try and will write what’s going on

Search for installed nouveau drivers.
If you will find them - uninstall them.

Can’t uninstall the nouveau drivers, because I haven’t booted the system. The screen is appearing on boot from the flash drive.

Boot to terminal and run yast from command line.

At boot menu press ‘e’ find line starting linux or linuxefi press end key to go to the end of that line add a space and a 3 press F10 to continue boot. Log into terminal as root type Yast. Use tab and arrow keys to navigate to software management remove nouveau. Exit Yast type reboot

Seems to bee some confusion about the state of your machine. As I read the posts, you have NOT installed opensuse, but are trying to test a live session from a USB stick. If that is the case, you are correct that there is nothing to uninstall.

You need an option in the boot menu to use a video driver other than nouveau to start the test. I do not know the correct command for that, but someone here should be able to give it.

looks like an AMD CPU issue - add iommu=pt to the boot linux line - I have to do that to every AMD CPU or it hangs up

Hi, guys,
I read all your posts and tried to boot tumbleweed with iommu=pt option but still no success, neither 15.1, nor Tumbleweed boots up to desktop, but after some thinking ends with the same screen as I posted above. I have no idea what to do.

In BIOS change iommu to software not hardware

There is no IOMMU in my BIOS, but I found SVM Mode that says it’s a CPU Virtualization. I changed it to enabled and now will try to install opensuse again.


I have an Asus FX 505D and it has almost the same specs as yours. I have the same problem as you, since that laptop will not work with the 4.x kernel series so you will fail no matter what you do, believe me i have done what you’r trying to do. What I did was I’ve install 15.1 from my desktop using may ssd and upgrade the kernel from the kernels stable repo

uname -r yields


Then I use that ssd and put it in my laptop since the laptop only has an NVME M.2 that has windows in it. The SATA hdd port is empty. After that all went smooth. I’ve booted my suse install without any problems. I’ve yet to find howto control the backlit keyboard because it keeps on changing colors on it’s own :-). The light I can switch off and on via kde battery power management, What really surprise me is that the REALTEK wifi card works out-of-the-box with the kernel that I’m using now. Oh btw vbox from oracle works just fine i’d just have to run


after I have switched to the latest and greatest kernel. Now I have to play with howto use secure boot with this laptop. :slight_smile:

Congratulations on getting it working.

Thanks, I really hope 15.2 will have the 5.x kernel series with all the backports from the greatest and latest kernel. :slight_smile:

Thus far, it looks as if 15.2 will have a 5.3 kernel.

Great, that is music to my ears.

Well, it seams I’ll wait for 15.2 to come out, until then I will stay on Win 10

Finaly I solved the problem. My bad, something went wrong with the Rufus software wich I used to write the opensuse image. I recreated the flashdrive and installed tumbleweed without any major problemsq except that opensuse didn’t like much my nvidia gtx1650 until I installed the proprietary drivers. The second problem was the rtl8821ce wireless adapter but I found a driver for it on

Thanks for your support and Happy New 2020 Year to all of you

It’s good to hear that you have things working.

Okay, it is Tumbleweed instead of Leap 15.1. But that does give you a newer kernel, which your hardware seems to need.

ثبت نام بدون کنکور دانشگاه علمی کاربردی](ثبت-نام-بدون-کنکور-علمی-کاربردی/)

شرایط ثبت نام بدون کنکور علمی کاربردی](ثبت-نام-بدون-کنکور-علمی-کاربردی-98/)

ثبت نام بدون کنکور وزارت بهداشت](ثبت-نام-بدون-کنکور-وزارت-بهداشت/)