Cannot boot OpenSUse 11

> Still no answer for my main question.

ok, let me try to answer your main question (trouble with RAID,
trouble with booting) as clearly as i can:

there is NO way to fix your system until it is known WHAT the problem
is…and, the problem could easily be the result of installing a
hidden and mostly impossible to find code fault from less than 100%
pure install media…

it is a useless waste of time to try to find the one (or more) little
error(s) which caused your install media to fail the check…

never install from faulty media, unless you want to run around in
circles trying to figure out what is wrong…

the easiest way to begin to fix this problem is to backup all user
data and use a 100% correct and pure DVD downloaded (or purchased)
from and select “Repair Installed
System” on this screen: then, if that
doesn’t do the trick, then select “Repair Installed System” on this

now, that may not cure your RAID problem (imo, it likely will)…but,
it will remove the possibility that the problem was introduced during
installing from a faulty disk…


Note: Accuracy, completeness, legality, or usefulness of this posting
may be illusive.

I guess you misunderstood me, goldie. I updated my kernel via Online Update. I wish I wouldn’t have done that at all. After that my system wouldn’t boot. Now I tried doing mkinitrd and the system fails with evil “Waiting for device /dev/md0” to appear. That’s my problem. I wanted to upgrade OpenSUSE to 11.1 using that faulty CD but it simply won’t see my RAID arrays. Whereas previous versions do see them.

> I guess you misunderstood me

i did, sorry.


Any help would be appreciated

Finally, the problem has been solved on my own.

I thank everyone who replied in this thread.>:)

eldar g wrote:
> Finally, the problem has been solved on my own.

would you, for those that follow who may have the same prolbme, please
mention what you did to solve the problem…please


Everything turned out to be very simple. When my system would fall back upon boot with evil “Waiting for device /dev/md0 to appear” I decided to check whether md module was loaded. Before that I used “mkinitrd -f md” but **cat /proc/modules **showed there were no familiar modules.

I booted from the rescue cd again. Checked that RAID was identified with cat /proc/mdstat. CHecked the loaded modules with cat /proc/modules and found that dm module was loaded. I always tried to use md whereas dm should have been used. Then everything was simple

Mounted /dev/md0

mount /dev/md0 /mnt,
mount /dev/sda1 /mnt/boot,
mount -o bind /dev /mnt/dev
mount -o bind /proc /mnt/proc
mount -o bind /sys /mnt/sys

**chroot /mnt

mkinitrd -f dm**

and system booted. I felt stupid but I guess every newbie comes across such situations:)

But another question arose: dm is used instead of md whereas I read about md-mod in the forums related to OpenSuse