Cannot boot into new 4.20.0-1-default kernel

Ever since I installed the latest kernel (4.20.0-1-default), I cannot boot into it.

I get as far as the 3 green dots in the middle of the screen and then a blinking cursor at the top left and have to press reset and reboot.

I can however, boot successfully into 4.19.12-1-default kernel every time. I get the 3 green dots and then a logon screen.

My grub is on Fedora and the grub on TW is on hold, kept from updating:

grub2 grub2-branding-openSUSE grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin grub2-x86_64-efi ruby2.5-rubygem-cfa_grub2

Scrolling down the Grub menu to openSUSE Advanced and pressing enter then selecting this menuentry created by Fedora for openSUSE will not boot:

        menuentry 'openSUSE Tumbleweed, with Linux **4.20.0-1-default** (on /dev/sdc7)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.20.0-1-default--545d0f15-9570-44ee-8404-9885bdc38d$
                insmod part_gpt
                insmod ext2
                set root='hd2,gpt7'
                if  x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,gpt7 --hint-efi=hd2,gpt7 --hint-baremetal=ahci2,gpt7  545d0f15-9570-44ee-8404-9885bdc38dfc
                else
                  search --no-floppy --fs-uuid --set=root 545d0f15-9570-44ee-8404-9885bdc38dfc
                fi
                linux /boot/vmlinuz-4.20.0-1-default root=UUID=545d0f15-9570-44ee-8404-9885bdc38dfc splash=silent resume=/dev/disk/by-uuid/bbc771f8-ba61-4e50-aeca-d2754b112aee quiet
                initrd /boot/initrd-4.20.0-1-default
        }

However booting into the previous kernel just below that will work every single time:

        menuentry 'openSUSE Tumbleweed, with Linux **4.19.12-1-default** (on /dev/sdc7)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.19.12-1-default--545d0f15-9570-44ee-8404-9885bdc3$
                insmod part_gpt
                insmod ext2
                set root='hd2,gpt7'
                if  x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,gpt7 --hint-efi=hd2,gpt7 --hint-baremetal=ahci2,gpt7  545d0f15-9570-44ee-8404-9885bdc38dfc
                else
                  search --no-floppy --fs-uuid --set=root 545d0f15-9570-44ee-8404-9885bdc38dfc
                fi
                linux /boot/vmlinuz-4.19.12-1-default root=UUID=545d0f15-9570-44ee-8404-9885bdc38dfc splash=silent resume=/dev/disk/by-uuid/bbc771f8-ba61-4e50-aeca-d2754b112aee quiet
                initrd /boot/initrd-4.19.12-1-default
        }

So, I’m currently stuck with the previous kernel for now and cannot figure out why.

cavsfan@openSUSE:~> uname -r
4.19.12-1-default

The 3 green dots is probably from Plymouth.

I would suggest that you edit “/etc/zypp/zypp.conf” and add “oldest” to the “multiversion.kernels” line. The idea is to make sure that your 4.19.x kernel does not get removed.

Have you tried booting with “nomodeset” appended to the end of the boot line?

To do that, hit ‘e’ on the grub menu entry, and scroll down to a line that starts “linux” (or maybe “linuxefi”). Then append " nomodeset" to the end of that line. Then hit CTRL-X to continue booting.

That’s just a test. You possibly have a video driver issue, and “nomodeset” can often bypass that.

Hi
The nvidia driver support is not built for 40.20.0-x yet, so switch to the hard way perhaps? Another thread here;
http://forums.opensuse.org/showthread.php?t=534679

No issues here the hard way with the 4.20.0-x kernel and 410.93 (GeForce GT710), installed kernel-default-devel and gcc, set boot to multi-user.target and manually run the Nvidia run file with the -aq option.

Thanks!
I tried nomodeset on both my custom grub entry first and then the one in the 1st post and got the same thing: flashing line cursor at the top left.

I did add “oldest” to the “multiversion.kernels” line in /etc/zypp/zypp.conf though.

Thanks I’ll try that. I managed to install the most recent Nvidia driver directly from Nvidia in Fedora 29, Hopefully I can do it on Tumbleweed.

Yesterday, I was doing the steps to install the Nvidia driver the hard way, I got to a certain point and printed out the pages I’d need and figured I’d finish up the next day.

Then today I downloaded Nvidia driver NVIDIA-Linux-x86_64-415.27.run released on 01/15/19 and I got almost to the point of installing it and seen I had 115 updates waiting and the updates involved a new kernel and a new Nvidia driver.

So, I installed all of that and rebooted and my custom grub entry worked, which boots to the last installed kernel so I knew the new kernel fixed my problem.

cavsfan@openSUSE:~> uname -r
4.20.2-1-default

There may be some superfluous things in this menuentry but, the important thing is it works with the UUID of openSUSE TW and swap for resume:

menuentry 'openSUSE Tumbleweed' --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-545d0f15-9570-44ee-8404-9885bdc38dfc' {
        insmod part_gpt
        insmod ext2
        set root='hd2,gpt7'
        search --no-floppy --fs-uuid --set=root 545d0f15-9570-44ee-8404-9885bdc38dfc
        linuxefi  /boot/vmlinuz root=/dev/sdc7 splash=silent resume=/dev/disk/by-uuid/bbc771f8-ba61-4e50-aeca-d2754b112aee quiet
        initrdefi /boot/initrd
}

The “linuxefi” and initrdefi" are only on Fedora 29. That is just the way their grub is.

I had no idea that the video driver support was not built into that 1st 4.20 kernel, so thanks for pointing me in that direction.

Problem solved but, I have the instructions to install the driver the hard way and I will should I have a problem like this in the future.

The thing is quite simple you have to download everything you need to compile

sudo zypper in -t pattern devel_C_C++ devel_kernel

I then blacklisted the nouveau so even if the nvidia driver fails I still share the graphical session with the generic drivers

sudo echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf 

Then download the appropriate Nvidia drivers from the site https://www.nvidia.it/Download/Find.aspx?lang=en

Put them in your home and rename them in Nvidia.run for convenience

Restart and go to the console Ctrl + Alt + F1 or F2 you become super user and then proceed to install them

sh/home/bin/Nvidia.run

I put a random directory to give an example
Follow the instructions from the terminal and at the end reboot, in any case better use the Repository and use the previous Kernel if the last one does not work
From uninstall

nvidia-installer --uninstall

Thanks for that. I already printed out the instructions 6 pages double sided, so 3 pages. Love how my printer does that.
The single hardest part I could not figure out before when I did it on Fedora 29 was stopping the Nouveau driver from running. It used to be done by typing in “telinit 3”.
Now, when you boot up you add nomodeset 3 to the grub line and that does the trick.

I was to the point where I was ready to enter:

sudo zypper rm drm-kmp-default

Then I decided to wait until the next day and the updates fixed my problem with a new kernel and new driver.

But, I’m getting ready to install the latest driver in a few.

I meant to say nomodeset 3 does both; stop the Nouveau driver from loading and the 3 ensures the system boots to a virtual console instead of a DM /Xorg session.

Wondering why I could not edit the previous post. Maybe that is just the way this forum works, which I’m fine with. :slight_smile:

… because you have only a few minutes window after you post in which to edit your post.

The reason is to avoid confusion in case someone quotes it in a reply that will look like a reply to something that does not exist or has been changed.

Thanks for the explanation. That makes a lot of sense and I have seen examples of what you are saying.

Meanwhile I should have seen this command was meant for Leap but, I doubt it wouldn’t harm Leap too.

sudo zypper rm drm-kmp-default

Which deleted my kernels. rotfl!

Luckily, I have backups and nothing like cleaning up the cruft with a fresh install. lol!

I’m installing the Nvidia driver 415.27 before I get to doing much else because of having to set coolbits to 4 in the Xorg file so, I can get my GPU fan running.

After trying at least 5-6 times to install Nvidia’s latest driver, I gave up and just went back to the G04 driver 390.87. I know it was something about blacklisting nouveau, which I had done accoding to the directions.
I even tried the G05 driver again and got the same thing - blinking cursor.

I mean I did that many clean installs because all I ever got was a blinking cursor at the top left. If I booted in recovery all I got was a bunch of text that would display then go blank and repeat over and over.

But, I’m not interested in installing the driver directly from Nvidia any more. I read you have to uninstall it before you update your system, so no thanks.

Gee, the last install I set to login automatically and wanted to change to not to login automatically but, got the blinking cursor.
Thinking I was going to have reinstall, I booted into TTY1 and edited /etc/sysconfig/displaymanager and added my userid back in and then it booted.

I’ll just leave it on autologin.

c’est la vie

Hi
No, no need to uninstall before updating, the only thing you have to do when a new kernel arrives and is installed is to boot to multi-user (runlevel 3, init 3 etc) and run the *.run file again, it uninstalls the old build and rebuilds against the running (new) kernel, then once done reboot… for me it’s a few minutes to do, then backup and running…

It is sometimes difficult to understand where the problem lies through the information posted, it is probably only a detail that prevents it but difficult to understand online … I recommend using the Repository, it is now more than two years that I use it, and even when there are updates not synchronized with the Kernel, I choose the next to the Grub and works, as I see it has no advantage to using the latest Nvidia Driver if the one in use works well, the computer must work … …and enough and that’s just what I want .

Thanks for that information. That doesn’t sound so bad once you got the driver installed.

Indeed, repos are the way to go unless you have some specific need for the latest driver and I do not really.

I may try it again. I don’t like to think I can’t do it. I did it on Fedora 29 and I’ve done it many times on other Linux systems.

Ciao
I did not want to preach it, sorry if you thought about this, unfortunately, Linux systems have slight differences in ‘installing the proprietary drivers, and sometimes a detail makes a difference recently, read well what it tells you when you’re init3 and are proceeding to’ installation of the hard way drivers to me it happened that it was blocked because it found a file of the type 0Xlog or something similar, it was enough to delete it directly from li> rm -rf and the path of the file and then everything proceeded to the best :wink:

Ciao
No problemo. I understand what you are saying and know it was something I left out to blacklist the Nouveau driver most probably. But, I’m good with the G04 driver 390.87 from the Nvidia repo.

About 6 or so years ago it was much easier to install the driver directly from Nvidia with telinit 3 etc. but, it has gotten more complicated and just installing the driver from the repo saves time, effort and headaches. :wink: