Cannot boot if external hard disk is not connected

Hi folks,

I just bought a new external hard disk for backup.

Today I configured the /etc/fstab file to have the disk automatically mounted to a specific point (a directory which I created in /mnt) when the system boots.

Problem is that now the OS requires the external HDD to be connected to PC all the time, otherwise it won’t boot.

Is there a way to have this issue solved and still have the HDD automatically mounted (when connected to PC)?

Thanks for your help!


Add nofail to the options

Thanks, it works now.

I have another question regarding external HDDs: how should I proceed to change the ownership and permissions of the files/directories contained on the hard disk? I tried in various ways with chmod/chown (in root mode: su -c), but it seems to have no effect although no error is shown. The permissions remain: root root rwxrwxrwx. I would like some of the directories to be owned by root (and not be accessed by regular users) while others would be assigned to a user.

I suppose the hard disk uses NTFS or FAT as filesystem?
Then you cannot change the permissions. Those filesystems know nothing about Linux’s users and file permissions, and FAT doesn’t support different users at all.

There is a way to use Linux users/permissions on NTFS with ntfs-3g, and even “map” them to Windows users, but I never tried that myself.
“man ntfs-3g” might help though. Apparently you have to set the “permissions” mount option at least.