Cannot boot, GRUB bug

hello guys.

Here’s what happened:
I had problems booting SUSE, it would start the boot and it wont finish, itll stop when its trying to load vexec something. That doesn’t really matter, because i went ahead an tried to repair the system, but as I repaired it, GRUB doesnt show booting windows as an option any more. On top of that, It didn’t really fix (the repair) my first problem. I have no idea what happened. Luckily, I recently updated to SUSE so i decided to make a complete new installation since everything was working so nice and it all just turned arround in one day. Any suggestions though what do to if that happens again?

Thanks a lot.

On Thu, 05 Feb 2009 22:06:01 +0000, A13kSAk3 wrote:

> Any suggestions though what do to
> if that happens again?

Based on the information provided, it sounds to me like a kernel update
didn’t complete successfully (and didn’t rebuild the initrd or properly
update /boot/grub/menu.lst). So, assuming that to be the case, if this
happens again, rather than repairing the system, try ‘boot from installed
system’. This will use the already-running kernel from the DVD and boot/
mount everything from the existing system. If this works, then you can
manually download and install the kernel update.


Randy Goddard

“It is pitch black. You are likely to be eaten by a grue.”

Thanks for the response.

Randy, I can see that working in versions of Suse 10.x. But what to do if it happens in 11.x where (IIRC) there is no option to boot the installed operating system? Or is that option around somewhere but I can’t find it?

True, I mean I tried it and it’s not in the menu that is run by the disc? Btw, it happened again. And now I’m just like completely screwed. It won’t run from disc, the only thing I can possibly do again is to just completely reinstsall it, Repair does not help!

I think this may be due to known bug that, last I looked, had been fixed and was working its way towards the Updates repository. The problem is probably with a corrupted /boot/grub/menu.lst file. If you don’t want to reinstall again, you can fix the file manually. What do you have, LiveCD or DVD or both?

DVD installed.

When you start the machine now, what exactly do you see (after the bios loads) - an error message, a menu, what?

Boot from the DVD into Rescue, at the prompt login as root. Then do:

fdisk -lu

And post back the output here. It probably will not be too difficult to get Windows booting again, and fix the grub problem, once we see disk layout.