Cannot boot from LiveCD or LiveUSB

I have a HP 6730s with a Radeon HD3450 running Windows 6 x64. I am trying to install openSUSE 11.4 on a USB stick from within Windows.
The problem is I cannot boot from a live CD or a live USB and I believe same thing is gonna happen when I’ll try to boot from USB containing the installation.
Sometimes when I try to boot CAPS let starts blinking and that’s it. It stays that way for hours. Also, sometimes my computer freezes and it displays a scrambled image and random colors on screen, like the times when the video card/driver crashes.
Moreover, I tried to install openSUSE 10.xx back when I bought the laptop but it failed. It installed fine and when it first boot up, it started Yast to configure the system and the video driver crashed(i guess) and also the GUI.
I don’t have any other problems with other distros, KNOPPIX runs just fine and even Compiz runs great. Right now I use openSUSE 11.4 in VirtualBox and it runs fine, including Compiz.
Any ideas?

You said
I am trying to install openSUSE 11.4 on a USB stick from within Windows.

You should be booting the CD or the USB

Have you tried:
Text mode install from liveCD

Oh, I said I am trying top install openSUSE on a USB drive but the thing is I cannot boot from a live USB drive or live CD and when I try to install on my laptop(not on the USB) all I get after installing(i manage to install) is text mode. So I am trying to fix this before I isntall on USB drive.

It should work on that Laptop
You should try booting with nomodeset added to the boot arguments or use the failsafe boot option

You might want to check this
openSUSE Forums - ATI driver with atiupgrade

I would forget the install to usb idea