Cannot boot existing 11.3 nor reinstall it

Hello everyone

On my Desktop I am experiencing a very weird behavior. First of all, I would like to mention that I am posting from the very same machine…just under Windows (which tends me to roll our hardware issues).

Next, a short history :wink:

  1. I installed 11.2 on my machine when it came out last year.]I upgraded my hardware (new mainboard, cpu, …) without reinstalling. Everything went fine]I upgraded to KDE 4.4…still everything ok*]I did a system upgrade to 11.3 final using zypper
    And there it starts. After the upgrade, the first boot didnt work as expected (the system just hang). So I just did a restart and 11.3 was up and running.
    Now, since last week, I cannot boot my system at all. The screen just shows me the boot-splash but the progress bar isnt moving a thing. So I started with the option splash=verbose which did not show me a single line of output. The system just hangs right after the GRUB selection occured.

So I decided to download 11.3, burn it to a disc and reinstall it. Well…this doesnt work either!
At least it shows me some lines of output, which look fine, but some lines after starting KDM the screen goes black and thats it.

The only way I got something was when I started the installation in Textmode. I was able to log in but I dont know what to do then. I ran yast2 but it didnt look like I could install the system that way.

Can anyone help me out please? It would be nice to get it running with my home-partition still in place.

Sounds like a graphic card driver issue. Depending on what you have NVIDIA, ATI ?? go to the “unreviewed howto” subforum there are a few ways described how to install the driver "so-called"hardway

cheers Otto

It does indeed sound like a graphic card issue. Sax2 has been removed from 11.3, but what works is Xorg -configure.

Thanks for the quick replys.

Graphic card might indeed be the cause. I am running two ATI HD2900 in Crossfire-mode.

Strange thing is that it worked for about one week. Anyway: how would I be able to run Xorg -configure when I cannot even start in Failsafe-mode?

When Grub comes up…there is a Boot Options line a bit further down

nomodeset 3

this will start the system and will ask for login.

On 2010-08-02 21:36, Macro81 wrote:

> Can anyone help me out please? It would be nice to get it running with
> my home-partition still in place.
> Marc

You should have left 11.2 intact and install 11.3 on a different partition in order to test it.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

Thanks everyone for the help

The bootoption nomodeset 3 worked and I got to my console. Xorg -configure didnt work, so I thought that a new driver version might work.

I came across this neat script (german)which downloads and installs everything automatically. I guess the stardard ati-installer would have worked as well…

Thanks again…my system is up and running again*
– Marc

*just a little problem with no buttons on any plasma widget but that will be another post and was already prior to the upgrade