Cannot boot after upgrade to 15.0

Working on the last machine to upgrade, a 64bit dualcore desk machine with ext2 disk and Nvidia video card.

Did a live upgrade and all was apparently well until I tried to reboot. It does the usual messages upto grub stage2 when the screen blanks and it starts booting again. I have nothing with which to modify. What can I do? Total reinstall would be a pain but I suppose is an option.

Yes I did remove the Nvidia repository before upgrade.

Try adding " nomodeset" to the end of the boot command line. Hit ‘e’ on the grub menu line, scroll down to find the line that starts with “linux” (or “linuxefi”), then hit the END key to get to the end of that line.

I don’t know if it will work. But it might get you booted so that you can uninstall the Nvidia driver and perhaps install the newer Nvidia driver.

Sorry I do not get to the boot command line. It looks just after the message about grub stage2. It blanks rather too fast for me to read. It seems as if grub is corrupted

How are you booting?

Maybe you have repeated upgraded and are still using legacy grub.

If you are using Windows boot manager for booting, then you need to update the boot file that you configured it to use.

In short, you have not given us enough information about what you are doing.

Another thought; is there a Leap 15.0 rescue disk?

I have not found one, just full. net install, and two live systems for KDE and Gnome, neither of which I know.
I would think that a rescue disk would allow me to check the Nvidia drivers and rebuild grub configuration.

This machine is quite old and as far as I know used grub to boot. It has never run any operating system except opensuse; not sure which was first but if necessary I should be able to find out; it was new in November 2009, so whatever was current then. No windows. My other desk machine is actually from May 2009 and I updated it Saturday and that went smoothly (ATI video)

What other information does it need? It was running 42.3 with no problems, has one 500Gb disk with one ext partition and a swap partition. Not sure about size of main memory but I think 4Gb. Said before is dualcore AMD, and ran fvwm on X11, no KDE or gnome. Actually my wife’s machine…

I am seeing:

It probably uses XFCE.

Maybe a quick check:

If you have “/boot/grub/menu.lst”, and if it has a recent date, then you are probably using legacy grub.

If you have “/boot/grub2/grub.cfg” and it has a recent date, then you are probably using “grub2”.

I will try that rescue disk. At present as I cannot get the m/c to boot I have no ideas about the dates on /boot/grub/menu.lst but judging by the look of the menu in 42.3 it was running grub.

With the rescue disk I can confirm that it is configured to use grub. /boot /grub/menu.lst looks correct but on a straight boot it never displays the choices.

Using tty1 I can look around the disk after I found where it was mounted but cannot think what to try. For example how could I ensure it is using a simple Nvidia driver? If I can get it booted I could use yast/supper to build the correct driver.

For example if I did a Christmas to the reason disk would I be able to run stuff? Get the network up etc?

Sorry, not seen this level of problem before.

Last message got deleted

I can confirm that it is configured for grub and /boot/grub/menu.lst looks right.

With the rescue disk I can see the files using tty1 but cannot think what to go. The message I see flashed on the screen says it is starting stage2 of grub, so I guess either the configuration is different or stage2 is corrupted.

What do I do now?

I would suggest installing grub2.

Here’s what to try:

1: Boot from the rescue disk. Use “su” to become root.
2: Mount your root partition

mount /dev/sdaX /mnt

(change that X to the appropriate value)
3: Mount your home partition at “/mnt/home” – probably not needed, but it won’t hurt.
4: Mount any other partitions, such as a separate “/boot” if you are using one.
5: And then:

mount --bind /dev  /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys

6: At this stage you should have everthing mounted. So now:

chroot /mnt

and that should put you inside your mounted partition.
7: It now gets tricky, but I think you will find this the easiest:


That should put you in a command line (ncurses) version of Yast. Get to the bootloader section. And switch to using “grub2” instead of using “grub”.
8: exit (leave the “chroot” mode) and reboot.

There are alternative ways of doing this that don’t use yast. But give it a try with yast.

Fails at first stage! The rescue disk runs xfce and I do not know how to stop it.
From tty1 I log in as root
Try mount /dev/sda2 on /mnt and get error message “/dev/sda2 already mounted or mount point busy.”

I tried using the mount point from xfce and followed the instructions. Reboot took a long time and gave error messages about at3 and SRTB errorno 16 but it came alive, albeit with gross character sizes. I guess I need to install Nvidia drives for G02.

Thank you for getting me this far.

Hmm. XFCE seems to want to mount everything. It’s what I don’t like about XFCE.

You should be able to logout. And then, on the login screen, choose “icewm” for login (instead of XFCE). That won’t try to mount everything.

When I have used the rescue disk, I have written it to a USB instead of to a DVD or CD. And it remembers that I wanted to use Icewm for login.

Odd. I am running Xfce on Several Machines, since 42.1 and now in 42.3, TW, & 15.0, and have never seen it mounting everything.

The only time I had that problem was in AV Linux (Debian/Gnu Linux) if you recall that issue, and it was a custom but undocumented change by the AV Linux Dev.

Got the same problem after upgrading opensuse leap 42.3 to 15.0, after the line “loading grub stage2” the machine reboots. It’s an AthlonX2 using legacy grub, /boot is on ext4. Grub has worked fine on it for 10+ years, so why change to grub2 :slight_smile:

I had an 42.3 net install CD laying around, so I booted the rescue system and runned grub-install. No joy.

I used the same CD to boot the installed 15.0 system (it booted as it should), and runned grub-install from there. No luck with that either.

I booted the installed 15.0 system using the CD, downloaded the grub rpm from leap 42.3 and installed using the command “rpm --upgrade --oldpackage grub-0.97-210.3.x86_64.rpm”, and then “grub-install”. And that actually worked :smiley:

Obviously something have happened to the legacy grub version supplied with leap 15.0. It’s not what I would expect, it is after all a legacy version and should not be subject for new development. I also noticed that the “stage2” file is a bit smaller in the 15.0 version than it is in 42.3.

Doubt there are many people here stubborn enough to still use grub legacy so I suppose it has not gotten tested much or at all. Might require a bug report to fix. Or you could just go with the flow and use grub2 which has worked fine for some time now.:wink:

I suspect upgrading to 15.0 from 42.3 never got any testing during beta because 42.x never offered to use Grub Legacy during installation. There was no way to automate a 42.3 installation to upgrade to 15.0, and no one doing manual testing had any inclination to try such a process.

Anyone else using Grub Legacy and wants to live upgrade should first do

# zypper al grub2*

It has worked for me at least 4 times with 42.3->15.0, countless times with TW.

I have lots and lots of openSUSE installations, TW, 15.0, and older. The only ones not using Grub Legacy are the few UEFI booting GPT disks. Grub Legacy does what needs doing on MBR disks, and still provides the gfxboot penguin that Grub2 still can’t offer.

Grub Legacy did get a retrograde rebuild sometime in the past year which 15.0 inherited from TW. In TW, I’m still using the 0.97-203.7 version, last working version I saved before the retrograde. AFAICT, the retrograde only affects its interactive shell, which most people, unlike me, rarely use.

Another potential problem with using Grub Legacy is it does not support the 64bit feature that recent versions of mkfs use to format EXT4. That’s OK with upgrades that don’t involve reformatting the / filesystem, and those using a separate EXT2 or EXT3 /boot/ filesystem, or if the reformat is done using the -O ‘^64bit’ (disable it) option.

I am stubborn enough to not go with the flow and use Windows and keep reinstalling it when bad things! Actually, abandoning that other OS gave me a peace of mind, and I can smile calmly when my colleagues cannot work because their computer suddenly decided it was more important to update Windows. And I do use grub2 on new installs, especially on machines using UEFI and GPT. But I see no gain in switching to grub2 on old machines.

It is not enough on typical openSUSE installation where /boot/grub2 sub-directories are on separate subvolumes. One need to mount at least them to make sure bootloader is installed correctly (if it comes to it).

He did say he was using “ext2”, so I doubt that subvolumes are involved. However, that’s a good reminder for people who are using “btrfs”.