Cannot boot after upgrade to 12.3 (fresh install on existing /home)

Hello Community,

I tried updating my Laptop to 12.3 today. After having finished successfully a network update, I restarted and the system stuck on “creating device nodes with udev”.

I then thought it would be wise to try a fresh install. So I did a fresh install. However, the installation required setting nomodeset as a kernel parameter and provided me with an ncurses interface. I installed nonetheless.

Now, when I boot without nomodeset I get stuck in

creating device nodes with udev

during the boot process. When I set nomodeset i get stuck in

 OK}Reached Target Graphical Interface 

.

This is all happening on a 64bit System, with a mobility radeon X1350 graphic card and 3 GB of RAM which used to be very happy with 12.2 until yesterday. My home folder is encrypted. The file system for root is ext4.

I have never before had such a bad installation experience with openSUSE on this machine. I know that prior to the fresh install I was able to boot with failsafe boot options (allthough graphics were not really usable). However, since the fresh install I have Grub2 and don’t see a failsafe option. I would really need this working till monday.

Any suggestions are welcome.

Does the system run from a Live USB?

I don’t know. I would guess that not, since it defaulted to an ncurses interface when installing. Just saw, the standard DVD has no live mode…so I will have to download a live cd first, if you think it is worth it.

No, it does not (I just tried the KDE live CD from a USB made with imagewriter)

https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/484228-12-3-radeon-modeset-boot-problem.html

Just found the above thread. I have exactly the same hardware and symptoms as the OP. I can now get to a terminal with Alt = F1 (thanks for that) when using nomodeset. I understand that the solution in my case is in post 18 of the above thread.

If I try #modprobe radeon modeset=1 then OS freezes
If I try #modprobe radeon modeset=0
#modprobe -r radeon
#modprobe radeon modeset=1
then everything is ok, and I’m able to start X

However, I do nor exactly get where this is supposed to be done. Still glad for any help, since I would prefer another sollution than staying forever with 12.2.

Nikos

PS: I also tried the solution in post 26 (adding radeon.modeset=1 as a boot parameter, however I then get stuck in “creating device nodes with udev” again.
PS2: when I run

sudo modprobe -r radeon
sudo modprobe -r drm
sudo radeon modeset =1
startx

I get into a usable graphicall interface, where do I have to make the relevant changes so that this is done on start?

@Nikos78

if a pure radeon boot is needed, suggest a read of

https://forums.opensuse.org/english/get-technical-help-here/hardware/486164-install-ati-radeon-hd-2600-issue.html#post2549944

hth

@Nikos78

if after trying the above the gui cannot be reach on reboot with the radeon
driver, try the following,

from the command prompt, login as root,
start yast and then enable network in ‘Traditional Method with ifup’,
again in yast System /etc/sysconfig Editor, search for NO_KMS_IN_INITRD and set it to yes
again in yast add repo Index of /mirror/amd-fglrx/openSUSE_12.3,
in yast program manager, search for fglrx, and select the appropriate driver,
and then install

if all has gone ok a reboot into the gui should be possible

hth

@Nikos78

apologies, ignore my post #7 above,

there is currently only radeon driver support for the radeon X1350 graphic card

I have created a page which describes symptoms and the solutions you should try in order, verify the symptoms match what you see
https://en.opensuse.org/User:Tsu2/12.3/Boot_Video_Troubleshooting

HTH,
TSU

Hello guys,

thank you for the suggestions. Unfortunately, I got a little anxious yeasterday and reverted to 12.2, since I could not risk having no working laptop on this monday…maybe I’ ll try again in a week or two.

Ok, since reinstalling 12.2 with the same user was not that easy either, I retried. I tried all suggestions of tsu2’s thread to no avail. What did the trick,however, was adding to /etc/init.d/boot.local,
the following lines:

modprobe -r radeon
modprobe -r drm
modprobe radeon modeset=1

and booting with the nomodeset kernel parameter. (The difficult part was doing this with vi ;))

Happy Eastern to everybody celebrating on this weekend.

@Nikos78

well done and thanks for the feedback

lots of people find nano easier to use than vi but the package has to be installed

cheers

For a while joe was installed by default and not nano but I notice the in 12.3 nano seems to be installed by default and joe is not. At least it is her from a KDE DVD install.

@gogalthorp

only upgrades to 12.3 have been done, so maybe that’s why nano had to be installed

cheers

Maybe mine was a new install. I rotate 2 partitions for root between versions. So I always do a new install. Coming from 11.4. I noticed that joe was no longer installed by default but nano was. In the distant past nano had a bug which made it run as ghost code and ate CPU cycles if you closed a console with it open. Have not tested to se if this still happens.