Cannot boot after update

Hello everyone,

I am facing a strange problem after installing the most recent updates (today - February 26th 2018, ~18:00) on my Zenbook.
After installing the updates, I told the system to reboot. Normally this is so fast I do not even get to see the shutdown screen, this time I did, for several minutes.
When the system finally rebooted, the boot process stopped at the console, telling me to either enter the root password for maintenance or hit Ctrl-D to continue.
Since the prompt gave me no indication of what might be wrong, and since I was impatient, I hit Ctrl-D. The display switched to a … kind of boot screen, I guess, a grey background with three green dots that lighted up one after the other. Then - nothing.

About the only thing I dislike about SSDs is that you cannot hear if they are busy, and the laptop has no HDD indicator LED. So I cannot tell if the system was doing anything at this point, or if it was just stuck.
I had the same problem on my desktop (also running Tumbleweed) where I was able pull the cart out of the mud by rolling back to a prior snapshot.

On the laptop, however, booting from an older kernel - 4.15.4 or 4.15.3 - or booting from a read-only snapshot gave the same result: Grey screen with three green dots that light up briefly, then nothing happens, as far as I can tell.
Just in case this is a hardware issue, I have powered down the laptop, disconnected the power supply and will try again in a few hours.

I mean, why would the system not boot properly off a snapshot? I have hosed my desktop twice over the last year (including today), and both times rolling back to a working snapshot has worked.

Unfortunately, as the grey-green boot screen is displayed, switching to a virtual console only shows me a - green - blinking cursor, but no login prompt, so I cannot look under the hood to see what might be going wrong.

Does anyone have a clue what is going on here or, better yes, how I can fix it? As long as my desktop works - I am writing this from my desktop, so it obviously works. :wink: - I can live without the laptop for a couple of days if that is what it takes, but I would like to avoid reinstalling it from scratch. (Which in turn would not be a disaster, either, but highly annoying.)

Thank you very much for any hints and suggestions,

Hit the e key at the Grub menu, remove quiet and splash=silent and add plymouth.enable=0 to the cmdline, then boot, watching for clues among the scrolling messages, which after logging in at the maintenance prompt (assuming you don’t reach your regular login greeter first) you can recover using dmesg and/or journalctl and/or other content in /var/log.

Thank you so much for your reply!

I did as you told me. After a while (longer than booting takes normally), the screen showed a prompt telling me that something was wrong and that I could log into an emergency shell by giving the root password, which I did, and then call “journalctl -xb” to look for clues, which I did, too.

The first sign of something going wrong is a message by systemd that it encountered a timeout “waiting for device dev-disk-by\x2uuid-…device”
The message appears again a few screens further down, twice actually, but with different UUIDs.

As far as I can tell from the output of dmesg, the disk - there is just one, an M.2 SSD, is detected without trouble, and the btrfs is detected, too, there are no error messages here. :-?

I am going to boot the laptop from a USB drive to see if the SSD is okay (it would be a real bummer if it wasn’t, I only replaced it a few months ago after the original SSD died), and then try the verbose boot from a snapshot.
I’ll post any new insights I can gather.

Once again, thank you very much,

Can you boot more normally by choosing from the Grub advanced options menu either prior kernel or one of the recovery mode selections? Others have reported booting trouble with the 4.15.5 kernel too.

On my desktop, booting a previous kernel version worked, as did booting from a snapshot; I reverted to the most recent snapshot before 4.15.5 and am holding off updates for now.

On my laptop, the problem with the grey boot screen remained, no matter what kernel version or snapshot I booted from. When I booted from a current Tumbleweed live medium and tried to mount the root filesystem on the SSD, the system became very unresponsive. At this point, I suspected the file system might be damaged, so I ran btrfs scrub, but after thirty minutes, “btrfs scrub status /dev/sda3” still said it had scrubbed 0 Bytes. Cancelling the scrub did not work, either.

I rebooted and tried to mount the root file system again, and it became fairly unresponsive again. (Not completely, just extremely sluggish.) With much patience, I could open a terminal and top, which told me btrfs balance was using lots of CPU cycles. I let it run for about two hours, but then the system was still sluggish, and btrfs balance was still running.

I decided that the root file system must have been damaged somehow and chickened out. I am currently reinstalling the system. I will post how it worked out when the installation is finished.

Thank you very much for your help!

Kind regards,

After a fresh install, my laptop is now running 4.15.6, everything seems to be working fine.

Thank you once more for your time and effort!