Cannot administer HP printer using HP-tools / HP-setup

In oS 12.1 I used to be able to administer my HP 3059A deskjet printer using HP-tools. I’d be able to open the device manager in HP-tools and stop / start queues, cancel jobs and add additional printers. Now with I am using oS12.2 and I can no longer do that. If I try add a printer with HP-tools or hp-setup I am able to find and select my network printer but when I try add it I get an error saying unable to connect to the cups server and that I need to be part of the lp group. I’ve added my self to the lp group but it doesn’t help.

I can add the printer using Yast>printer>etc and the printer works fine but when I do that it doesn’t show up in the hp-tools utility unless I start hp-tools as root. Can I not as a normal user add a printer to my system or administer my printer through hp-tools anymore?

Are you a member of the ‘sys’ group?

I had problems with the default hplip version in openSUSE 12.2 and suggest you add in the printing repository and upgrade to hplip 3.13.3. Here is the repositories:


I suggest you then open YaST / Software Manager, make sure the option to allow Vendor Change is selected, then select the Repository View, highlight the printing repository you added and then elect to Switch To This Repository. It should put all of hplip to the latest version and then see if hp-tools is working properly again.

Thank You,

No just the lp group. The thing is in 12.1 I didn’t even have to add myself to the lp group so what’s changed that I now need to add lp and maybe sys? I’ll give adding the sys group a try but there must be some reason why this is necessary.

I did as you say and it now works thanks. Although I’ve left myself a member of the lp group.

I not sure that being a member of lp makes any difference, but it does sound like a defective hplip was the problem. The issues was described as being “upstream” by our maintainers and thus only a newer version will provide a fix and no willingness to push the newer version into openSUSE 12.2 by them. Which just means you have to take this issue on yourself and use the newer version is the printing repository and carry on.

Thank You,

**I had a problem with my cp1025nw yesterday (different cause, same symptoms, also 12.2) and upgrading to 3.13.3 solved my issues. If you haven’t tried that yet I certainly would. I didn’t have to change any permissions or join any new groups. It just worked OTB (again).

Thanksjdmcdaniel3 and caprus. I’ll remove the lp group.

I am happy to help. Let me say that there was without a doubt a problem with the standard openSUSE 12.2 supplied hplip application and your only choice seems to be switching to the printing repository. If you use openSUSE 12.2 and use hplip, stop messing around with the issue and upgrade hplip from the printing repository.


Thank You,