Cannot add nvidia repository during 12.3 installation

During installation of openSuSE 12.3 32-bit, I tried to add the nvidia repository to get the proprietary nvidia drivers, but I could not get it to work. During installation, in the adding separate media step, there is an option to add a repository. I tried that, set up networking, and accepted the default selection of Main-OSS and Main-nonOSS. Those added fine. I then tried to add ftp://download.nvidia.com/opensuse/12.3/ by using the “Specify URL” option, but the next step to check repository type froze. The only way I got off that screen was crtl+alt+F1, then ctrl+c to kill the process and reboot. There was no problem with the repository; I could access it from another machine while the installation was frozen.

Is it intended behavior to not add other repositories, or a bug that needs reporting?

For me, including the nvidia proprietary drivers in the initial installation (see https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/485647-how-explaining-how-stop-12-3-installs-using-nvidia-cards-hanging.html#post2545624) does work around the install or boot issues some people report.

Regards,
Howard

FWIW

during the install of openSUSE12.3_64bit the repository
Index of /mirror/amd-fglrx/openSUSE_12.3
was added and the required graphics driver installed

so the problem described is not applicable with http:/ and 64bit

I’ve done this in the past, not on 12.3 (my current laptop has hybrid graphics and cannot use the default NVIDIA driver) and it’s been years since I used a 32bit version of openSUSE, AFAIK it should work. I used to add an ftp URL for the Packman repo as well. Just gave it a try once, it worked. I think the first time I tried was on 11.2

I tested a 64-bit installation and got the same result. Adding the nvidia repository got stuck at the “check repository type” step.

Maybe there is something odd about that specific repository.

Filed a bug report at https://bugzilla.novell.com/show_bug.cgi?id=816326

Howard

Might difficulty be within installation or adding the repositories ?

Does difficulty adding the repositories remain after all installation with updates, then re-start and updating to where no updates left, and no zypper ps issue show ?

The difficulty is only during installation. After installation completed, I added the nvidia repository normally with no problem.

If the repository could be accessed during operating system installation, that would be an easy way to get the nvidia proprietary drivers installed from the start. That could avoid the booting troubles lots of systems with nvidia graphics have been experiencing right after installation.

Howard