Cannot Access My NTFS Partitions

I don’t know if this is the best forum to ask this, but I really, really, really need help!

All my data is on my Windows partitions (Vista is installed, using NTFS). I’m trying to switch to openSUSE, but it’s pretty much useless without being able to access the data in those partitions.

Several days ago, I installed Linux Mint, and had no problem accessing my Windows drives drives. They weren’t always mounted after booting, but if I opened File System and then media, they were listed there (as Vista and Data) and I was able to mount them at that time.

A couple of days ago, I decided to switch to open SUSE and installed 11.0 with the GNOME desktop. My Windows drives showed up just fine, just as in Linux Mint.

Version 11.0 was still working this morning. Unfortunately, it didn’t last. I decided to upgrade, so I downloaded the 11.1 DVD and installed the new version with KDE. Now I was completely unable to see my Windows drives no matter what I did. I did upgrade installs, new installs, repair installs, GNOME, KDE, and everything I could think of. I can’t even count the number of installations I did today.

The only thing I could think of that happened between running 11.0 and 11.1 was that I had installed the BootIt NG partition manager. Tonight I uninstalled it and reinstalled openSUSE. No luck.

I then booted from the Linux Mint live CD and tried again. My Vista and Data drives didn’t show up on the desktop, but I opened up Nautilus and there they were in the media directory, and they mounted without problems.

Okay…I reinstalled openSUSE 11.1 (AGAIN!), and I’m back to square 1. Vista and Data not only don’t show up on my desktop, but they aren’t in the media directory, either!

I decided I would try mounting the drives from a command prompt (I checked fstab and they were there). When I did, I got an error message saying “Mount failed: Device or resource busy.” I can’t image how the drives could be busy, since I can’t even access them.

Can someone please tell me what’s going on?

Thanks in advance!

HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

With all that you had going on., it’s difficult to say where the situation might lie at the moment. So execute a few commands in a console to tell us what’s happening now.

sudo /sbin/fdisk -l

will tell us where the partitions are, including NTFS

cat /etc/fstab | grep ntfs

will tell us what attempts are being made by fstab to mount the drives when the system boots

sudo mount | grep fuseblk

will tell us what NTFS drives are actually mounted if any

So can you do that and copy/paste the dialogue back here and we’ll try to take it from there.

Thanks for the replies.

I don’t know that I had that much going on. I just installed and uninstalled BING, and reinstalled Linux several times. Each time, the / partition should have been formatted (except for the one upgrade I tried).

In any case, thank you for the commands, and caf4926, for the link. They were all very helpful; I learned a lot.

In the end, I found that the drives were there all along. Version 11.1 put them under a /windows directory, instead of /media. Also, I think what had me most confused of all was that there were no longer “shortcuts” on the desktop (or anywhere else) as there had been before. I will still need to figure out how to create those, and I’m still having problems assigning write privileges. I’ll probably eventually just have to set the permissions from the command line.

Thanks again!

If they are internal ntfs partitions, then use the yast partitioner tool to setup rw access for users. It will make the necessary fstab adjustments for you. The link you were given also explains how to do this.

On 11.0 [and I imagine 11.1 won’t be very different]
Rightclick desktop
-> Create New
-> Link to Location

Thanks. 11.1 is different, but I was able to create a shortcut on the desk.

As for write access–I’m just totally flummoxed and irritated. I tried Partitioner, and it gave me an unrelated error and didn’t change fstab. Neither did any of the other things I tried. I finally ended up editing fstab manually. It initially had:

users,gid=users,fmask=133,dmask=022

As suggested in the Swerdna document, I changed it to:

uid=1000,gid=100,umask=0022

Theoretically, that should give me ownership and full rights to the drive. However, I still do not have write access. Even as root, if I navigate to the drive in Nautilus, “Create folder” and “Create document” are both grayed out in the menu.

What am I missing?

Regarding this:

Can you please run the console command:

ls -l /path_to/mount/

replacing the path as appropriate to show the files on the NTFS partition and copy the output here.
Also please run these two command and copy the output here:

cat /etc/fstab | grep ntfs

and

sudo mount | grep fuseblk

Without those diagnostics it’s all really just more conjecture.

I just have the volume in fstab with “defaults” for the options. The mount point (/mnt/vista) specifies the owner as root, and the group as users. This gives all users read/write access to the volume.

Swerdna,

Here you go:

ls -l /windows/E
total 7401
-rwxr-xr-x 1 keith users 6129 2008-09-10 20:48 0x0409.ini
drwxr-xr-x 1 keith users 0 2009-01-14 20:40 Acronis Backups
drwxr-xr-x 1 keith users 8192 2008-12-13 11:35 Agent
drwxr-xr-x 1 keith users 0 2008-03-12 02:49 AJCBackupArchive
drwxr-xr-x 1 keith users 12288 2008-12-12 21:17 ClipMate
drwxr-xr-x 1 keith users 4096 2006-11-02 08:41 Default
-rwxr-xr-x 1 keith users 174 2008-08-05 01:07 desktop.ini
drwxr-xr-x 1 keith users 196608 2009-02-09 22:55 DL
drwxr-xr-x 1 keith users 0 2008-11-02 15:40 Driver Backup
drwxr-xr-x 1 keith users 0 2008-03-12 02:45 DVDfab Log
drwxr-xr-x 1 keith users 0 2008-03-12 02:45 FlashBack
drwxr-xr-x 1 keith users 32768 2008-03-12 02:45 HAWin32
drwxr-xr-x 1 keith users 0 2009-02-05 20:54 home
drwxr-xr-x 1 keith users 0 2008-03-12 02:45 IMAPSize
drwxr-xr-x 1 keith users 28672 2008-12-06 12:06 Keith
drwxr-xr-x 1 keith users 0 2008-08-05 23:40 Keyfinder
drwxr-xr-x 1 keith users 0 2008-12-28 11:28 MSDN
drwxr-xr-x 1 keith users 0 2008-07-02 21:09 MSOCache
drwxr-xr-x 1 keith users 0 2008-03-27 16:47 my documents
-rwxr-xr-x 2 keith users 7608832 2008-09-10 20:48 PhatNotes Professional Edition.msi
drwxr-xr-x 1 keith users 12288 2009-02-11 23:06 POPFile
drwxr-xr-x 1 keith users 8192 2008-11-30 20:24 POPFile - Copy
drwxr-xr-x 1 keith users 0 2008-02-25 20:32 PPC Backups
drwxr-xr-x 1 keith users 4096 2008-07-01 02:38 Public
drwxr-xr-x 1 keith users 0 2008-07-02 19:50 $RECYCLE.BIN
drwxr-xr-x 1 keith users 4096 2008-03-12 02:46 Seagate Free Agent
drwxr-xr-x 1 keith users 32768 2009-02-07 10:27 System Volume Information
drwxr-xr-x 1 keith users 8192 2009-01-09 00:26 The Bat!
drwxr-xr-x 1 keith users 4096 2009-01-08 23:29 ubuntu
drwxr-xr-x 1 keith users 0 2008-12-06 17:40 Users
drwxr-xr-x 1 keith users 0 2008-03-20 20:26 Users.Sav
drwxr-xr-x 1 keith users 8192 2008-11-06 20:55 Zoot32
drwxr-xr-x 1 keith users 8192 2008-11-06 21:00 Zoot.Old

cat /etc/fstab | grep ntfs
/dev/sdb1 /media/FreeAgent\040Drive ntfs defaults,nls=utf8,umask=0222,nosuid,nodev 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part5 /windows/D ntfs defaults,nls=utf8,umask=0222,users 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part6 /windows/E ntfs-3g uid=1000,gid=100,umask=0022,locale=en_US.UTF-8 0 0
/dev/sdc1 /media/FreeAgent\040Drive ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8 0 0

mount | grep fuseblk
/dev/sdb1 on /media/FreeAgent Drive type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda5 on /windows/D type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda6 on /windows/E type fuseblk (rw,allow_other,default_permissions,blksize=4096)

mingus,

Would it be possible for you to post an entry for clarification?

You’ve got a mixture of NTFS drivers (ntfs and ntfs-3g) and an inconsistent mix of “options”. And fstab seems to contain an entry for the one drive twice, the FreeAgent drive.

I’m puzzled as to why you can’t write to /windows/E (unless you aren’t the user keith=1000 who owns all the files in E given the current setup).

I suggest you edit fstab and make three of the lines consistent with each other so you have a common ground to work from. I suggest you make them like this and see how it goes:

/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part1 /windows/C ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part5 /windows/D ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part6 /windows/E ntfs-3g defaults,locale=en_US.UTF-8 0 0

and make the other two into commented lines like this:

###/dev/sdb1 /media/FreeAgent\040Drive ntfs defaults,nls=utf8,umask=0222,nosuid,nodev 0 0
###/dev/sdc1 /media/FreeAgent\040Drive ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8 0 0

And describe the Free Agent Drive and how it is connected to the computer, internal or external, usb, whatever, a good description.
And I forgot to ask for this diagnostic which would have sorted the Free Agent, so can we have it please:

sudo /sbin/fdisk -l | grep NTFS

Thank you VERY much, swerdna. After editing the fstab file as you suggested, I am able to create folders and documents in E. (I haven’t tried C, but I assume it will work, too. I don’t actually need to write to D.)

Here is the output from the additional command:

sudo /sbin/fdisk -l | grep NTFS
/dev/sda1 1 10197 81907371 7 HPFS/NTFS
/dev/sda5 10199 10325 1020127+ 7 HPFS/NTFS
/dev/sda6 10326 26908 133202916 7 HPFS/NTFS
/dev/sdc1 * 1 60801 488384001 7 HPFS/NTFS

Free Agent is an external USB backup drive.

I mthink that this:

/dev/sdc1 * 1 60801 488384001 7 HPFS/NTFS

Is probably the FreeAgent drive, which is likely a USB attached drive.

It can be treated two ways:

Option 1: If it’s permanently attached and always switched on it should be listed and mounted in fstab, recommended like this as the line in fstab:

/dev/sdc1 /windows/FreeAgent ntfs-3g defaults,locale=en_US.UTF-8 0 0

You would need to make a folder named FreeAgent in the directory /windows and then it would work. Note that the computer might not boot properly if you arranged it like that but did not have the drive powered up to boot. So it’s really only a good idea if the drive is acting as a permanent drive.

Option 2: No mount in fstab – allow the drive to automount. If you switch the FreeAgent on before booting, it will be sensed but not mounted. If you switch the FreeAgent drive on after booting it will automount. I believe in 11.1 it will automount read-write and I believe in 11.0 it will automount read-only, but it’s been a while since I checked. If you need it to be read-write because it only automounts read-only, you can apply a one-time fix to make it happen – check the fix listed on this web tutorial: Automounting external (USB) NTFS drives in read-write mode.

Well, months later, here I am again. :frowning: I thought I had this all working at one point, but it is not working now. Puzzled Penguin is right!

Despite making changes to fstab in several ways, changing owner and group, changing permissions, and everything I could think of, I still cannot write to my Windows partitions.

Here are the results of executing the commands requested earlier in the thread. Note that I have four NTFS drives: C, D, E, and FreeAgent Drive. The FreeAgent drive is an external backup drive that I’m not too concerned about right now. The one that I do really be able to write to is E; the others can come later.

sudo /sbin/fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x83bf52c3

Device Boot Start End Blocks Id System
/dev/sda1 1 10197 81907371 7 HPFS/NTFS
/dev/sda2 * 10198 30343 161822745 f W95 Ext’d (LBA)
/dev/sda3 30401 30401 8032+ df BootIt
/dev/sda4 30344 30344 8032+ df BootIt
/dev/sda5 10199 10325 1020127+ 7 HPFS/NTFS
/dev/sda6 10326 26908 133202916 7 HPFS/NTFS
/dev/sda7 30140 30343 1638598+ bc Unknown
/dev/sda8 29618 30139 4192933+ 82 Linux swap / Solaris
/dev/sda9 26909 27673 6144831 83 Linux
/dev/sda10 27674 28948 10241406 83 Linux
/dev/sda11 28949 29617 5373711 83 Linux

Partition table entries are not in disk order

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa4b57300

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 60801 488384001 7 HPFS/NTFS

cat /etc/fstab | grep ntfs

/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0

sudo mount | grep fuseblk

/dev/sda1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda5 on /windows/D type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda6 on /windows/E type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb1 on /media/FreeAgent Drive type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

Can anyone help? Please!

/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.U TF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.U TF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.U TF-8 0 0

to

/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part1 /windows/C ntfs-3g defaults 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part5 /windows/D ntfs-3g defaults 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part6 /windows/E ntfs-3g defaults 0 0

Hi,

/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part1 /windows/C ntfs-3g users,gid=users,fmask=133,**dmask=022**,locale=en_US.U TF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part5 /windows/D ntfs-3g users,gid=users,fmask=133,**dmask=022**,locale=en_US.U TF-8 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part6 /windows/E ntfs-3g users,gid=users,fmask=133,**dmask=022**,locale=en_US.U TF-8 0 0

You see the bolded dmask=022

change it to dmask=002 for each of the ntfs entries.

Good Luck,

Ian

Haha caf, that’s twice now we’ve both posted right after each other.

Either way will work, caf’s advice leaves less of a mess.

Good Luck,

Ian

Wow! Thanks for the speedy replies!

If I understand correctly, you’re just suggesting that I replace the specific user and group settings in the fstab line by “default”. Is that right?

If so, unfortunately, that was one of the things I already tried. It didn’t help, so I changed it back to the old settings.

I don’t need to reboot or log off/on after making any of these changes, do I?

edit fstab as I suggested

/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part1 /windows/C ntfs-3g defaults 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part5 /windows/D ntfs-3g defaults 0 0
/dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJD0P818049-part6 /windows/E ntfs-3g defaults 0 0


yes reboot!!

remember to leave an empty line at the end of fstab