Cannot access internet using opensuse 11.2

Hi there,

I have a dual-bootable machine with opensuse 11.2 and win xp. I’ve had this for a while (about 3 years) and the internet worked fine on both systems. But I recently moved houses and I noticed that I can connect to the internet on win xp but not on opensuse. I’m wondering what the cause could be. It’s perhaps something to do with the ISP, but surely if win xp can connect to the internet so can opensuse. Any suggestions? Many thanks.

Please provide some more information.

ifconfig
cat /etc/resolv.conf

Are You using ifup or NetworkManager ?
Can You ping 8.8.4.4 from openSUSE ?

As a side note suggestion please consider an upgrade to 11.3 as 11.2 is no longer supported.

Best regards,
Greg

Sorry for the late reply. Here are the outputs from those commands. I’m using KNetworkManager.

linux-wye1:/home/ia267 # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:13:CE:BA:44:63
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:17 Base address:0x8000 Memory:dfbfd000-dfbfdfff

eth1      Link encap:Ethernet  HWaddr 00:14:22:8A:59:83
          inet addr:172.22.159.254  Bcast:172.22.159.255  Mask:255.255.255.0
          inet6 addr: fe80::214:22ff:fe8a:5983/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5247 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3061 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:501530 (489.7 Kb)  TX bytes:243845 (238.1 Kb)
          Interrupt:18

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:70 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4324 (4.2 Kb)  TX bytes:4324 (4.2 Kb)

linux-wye1:/home/ia267 # cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
nameserver 194.168.4.100
nameserver 194.168.8.100

So I just checked my work laptop which has opensuse 11.1 installed, which also uses KNetworkManager and I’m able to connect to the internet and here’s the outputs (I can’t do ifconfig as I don’t have root access on my work machine).

ia267@malling:~>  cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search firerack
nameserver 172.22.159.61

Thanks

lostidentity wrote:
> I don’t have root access on this machine so unable to write the output
> of ifconfig. But the other one is
You do not need to be root to get the output just type


/sbin/ifconfig

as a normal user and it shows you the output, you only need to be root if
you want to change something with ifconfig.


PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
| 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.1 | nVidia
ION | 3GB Ram

On 2011-10-04 13:36, lostidentity wrote:
>
> Sorry for the late reply. Here are the outputs from those commands. I’m
> using KNetworkManager.

The requested output of the ping is missing. I would also like to see the
output of route.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

The pinging seems to work (the dots below are not part of the output, it’s just to show that it continued till I cancelled it)

ia267@linux-wye1:~> ping 8.8.4.4
PING 8.8.4.4 (8.8.4.4) 56(84) bytes of data.
64 bytes from 8.8.4.4: icmp_seq=1 ttl=54 time=190 ms
64 bytes from 8.8.4.4: icmp_seq=2 ttl=54 time=77.2 ms
64 bytes from 8.8.4.4: icmp_seq=3 ttl=54 time=40.9 ms
64 bytes from 8.8.4.4: icmp_seq=4 ttl=54 time=163 ms
64 bytes from 8.8.4.4: icmp_seq=5 ttl=54 time=192 ms
64 bytes from 8.8.4.4: icmp_seq=6 ttl=54 time=42.8 ms
64 bytes from 8.8.4.4: icmp_seq=7 ttl=54 time=78.6 ms
64 bytes from 8.8.4.4: icmp_seq=8 ttl=54 time=43.7 ms
64 bytes from 8.8.4.4: icmp_seq=9 ttl=54 time=47.8 ms
64 bytes from 8.8.4.4: icmp_seq=10 ttl=54 time=41.7 m
.
.
.
.
64 bytes from 8.8.4.4: icmp_seq=103 ttl=54 time=56.9 ms
64 bytes from 8.8.4.4: icmp_seq=104 ttl=54 time=40.8 ms
^C
--- 8.8.4.4 ping statistics ---
104 packets transmitted, 104 received, 0% packet loss, time 103153ms
rtt min/avg/max/mdev = 40.565/73.988/221.930/42.909 ms

On 2011-10-05 11:06, lostidentity wrote:
>
> The pinging seems to work (the dots below are not part of the output,
> it’s just to show that it continued till I cancelled it)

Then your problem is the DNS server.
You have to define one that works, following the instructions in
/etc/resolv.conf.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)