Cannot access DVD drive - inode/blockdevice

Hi, l have installed Opensuse 11.4 onto a Fujitsu L7320 laptop, and l cannot access the DVD drive although the OS recognises it as a NEC-DVD-RW ND-6750A. It correctly identifies the DVD label, but when l try to explore using Dolphin, l receive the error message:-

There is no application installed that can open files of the type block device (inode/blockdevice), and when clicking on the install option l then receive the message:-

The software to install could not be found in the currently enabled software repositories. It may be located in other repositories. See openSUSE: 安裝其他的軟體.

In frustration l have added all of the repositories and also downloaded the opensuse 11.4 iso file to have as an iso repository, but still no luck in exploring the DVD. I have also added my profile to the cdrom group, just in case it was a permissions problems, but still no use.

The output of the script /usr/sbin/hwinfo –cdrom is:-

20: SCSI 100.0: 10602 CD-ROM (DVD)
[Created at block.249]
Unique ID: KD9E.QDO6LXpqiqB
Parent ID: rKvl.p5yDu2DZM7E
SysFS ID: /class/block/sr0
SysFS BusID: 1:0:0:0
SysFS Device Link: /devices/pci0000:00/0000:00:0f.1/host1/target1:0:0/1:0:0:0
Hardware Class: cdrom
Model: “_NEC DVD_RW ND-6750A”
Vendor: “_NEC”
Device: “DVD_RW ND-6750A”
Revision: “2.42”
Driver: “pata_via”, “sr”
Driver Modules: “pata_via”
Device File: /dev/sr0 (/dev/sg1)
Device Files: /dev/sr0, /dev/scd0, /dev/disk/by-id/ata-_NEC_DVD_RW_ND-6750A, /dev/disk/by-path/pci-0000:00:0f.1-scsi-1:0:0:0, /dev/disk/by-label/openSUSE-DVD-i586-Build0024, /dev/cdrom, /dev/cdrw, /dev/dvd, /dev/dvdrw
Device Number: block 11:0 (char 21:1)
Config Status: cfg=yes, avail=yes, need=no, active=unknown
Attached to: #10 (IDE interface)
Drive Speed: 24
Volume ID: “openSUSE-DVD-i586-Build0024”
Application: “openSUSE-DVD-i586-Build0024-Media”
Publisher: “SUSE LINUX Products GmbH”
Preparer: “KIWI -
Creation date: “2011030214112700”
El Torito info: platform 0, bootable
Boot Catalog: at sector 0x02df
Id String: “SUSE LINUX Products Gmb”
Media: none starting at sector 0x02e0
Load: 2048 bytes

Any pointers would be gratefully received :slight_smile:

Many thanks


You should not try to open the block device, only the kernel should do that.

Because you talk about Dolphin, I guess you are using KDE (you do not tell).
When in KDE you enter a DVD in the unit, after a few moments the device notifier should pop-up with a message. When you click there you are offered several oportunities (depending one what device is detected). When there is a file system on the DVD, one of those options will be “open with Dolphin” (or similar text). Click it, the file system will be mounted (somewhere in* /media*) and you can browse (not on the block device, but on* /media/…*).

As I said it depends on what is on the device. E.g. when it is a new, unburnt device, K3B (for burning) will be offered. As you do not tell what is on the DVD, my guessing stops here.

Please explain if the device notifier does not pop-up in your case. And please tell what is type of DVD contents it is.

EDIT: adding batches op repos is not very wise. You better remove them again and stick toi the standard ones OSS, nonOSS, Update, Packman, maybe Nvidia when you have an Nvidia card.

BTW this brings me to the following: Did you install the Multimedia software:
When not there is not much change you can read a multimedia DVD.

Hi hcvv, many thanks for your reply, and definitely using KDE.

Sorry didn’t explain clearly that the operating system correctly mounts the cdrom device and it shows within “My Computer” on the desktop, however when l try and explore the cd or dvd l receive the message that additional software needs to be installed, and gives the option to install. The problem occurs after clicking install, as another message pops up indicating that the software could not be found on the software repositories, although l have the standard ones that you mention and also Packman.

Yast also clearly shows the cd rom device within media, and when l add an external usb cdrom device and try to explore the disk the same problem occurs, and l have used multiple disks to experiment, including oem cd roms and also burnt copies of the iso(s) for Opensuse and Fedora.

The problem seems to be more software related, so my apologies if l have listed in the wrong forum field :slight_smile: but any suggestions on a work around would be superb.



Opps, just re-read your reply and l haven’t installed the multimedia software yet, so will try that and will update later with the results.



Multimedia in One Click

But if you already have the packman repo you might want uncheck it being added again

Or look at this:
Multi-media and Restricted Format Installation Guide

Hi Caf4926, many thanks for your help and using the Multi-media and Restricted Format Installation Guide l can now access data / audio cdroms :slight_smile: