cannot access a smb share by name

Hello all,

I have some problems accessing a smb share by name. Few day ago I was able to access the share by name but seems that today I cannot access anymore. I tried to restart the computer … but nothing happened. Notice that the dns server is responding and is working correctly.

How can I debug this problem. It’s annoying because I don’t know all the IP addresses of our internal servers.

Thanks

Changes on the server side that you don’t know of ? If you did not change anything on the client side, something must have on the server side. Contact the admins.

You could try the command:
smbclient -U <username> -L <server ip or name>
This will show you shares on the server in the -L option.

The problem is that from Windows I can access the server by name.

The same problem here accessing by name. When I put the server IP it’s working fine.

Also I talked to admin and they said that nothing was changed regarding this problem.

Also I noticed that Pidgin cannot connect to my yahoo account because he cannot resolve a name.
Is there a daemon or something like that that resolves names into IPs?
Or…what configuration files involve the dns?

On Tue April 27 2010 06:26 am, ionpetrache wrote:

>
> The problem is that from Windows I can access the server by name.
>
> Knurpht;2157894 Wrote:
>> Changes on the server side that you don’t know of ? If you did not
>> change anything on the client side, something must have on the server
>> side. Contact the admins.
>
>
ionpetrache;

Samba name resolution is performed by nmbd. First verify that nmbd is
running.


ps -A |grep nmbd

Also verify that the Netbios Server is allowed through the firewall.

If this all seems OK it would help if you posted the contents
of /etc/samba/smb.conf. You can conceal any confidential information such as
public IPs by using substitute values.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Indeed this service wasn’t running but I tried to start from CLI and I get the same result.

I tested the dns with dig Google and I got the following:

dig Google

; <<>> DiG 9.6.1-P3 <<>> Google
;; global options: +cmd
;; connection timed out; no servers could be reached

I weired because opening the Google is working fine.

Seems that was a problem with /etc/resolv.conf file but… I don’t know why?

This is the actual resolv.conf file that works:

#@NETVPN_GENERATED@ – this file is generated by NetVPN

and will be overwritten by NetVPN

as long as the above mark is intact

nameserver IP_DNS_VPN1
nameserver IP_DNS_VPN2

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search saguaroprint.ro infoprint.com ibm.com boulder.ibm.com
nameserver IP_ourDNS1
nameserver IP_ourDNS2

The previous file that doesn’t work has this entry several times introduced in resolv.conf. I deleted all of them except one and now seems to work accessing smb share and yahoo messenger.

#@NETVPN_GENERATED@ – this file is generated by NetVPN

and will be overwritten by NetVPN

as long as the above mark is intact

nameserver IP_DNS_VPN1
nameserver IP_DNS_VPN2

Do you have any idea how can I restrict the access for the AT&T vpn client to write in this file cause this is the only one VPN client that I am using.