Cannon Pixma mp220

How to make it work?
It was automatically recognized when I was using ubuntu.Now opensuse suggests driver which doesnt work.Then I used gutenprint drivers and it just prints nothing.

Any suggesstion?

  1. gutenprint feels it should work for you

Driver: gutenprint | OpenPrinting - The Linux Foundation

what do you see if you open cups?


  1. here is a link to Canon linux drivers for the MP210

I can only suggest you try that; if the above does not work


you need the rpm version as you wish to use OpenSuse;

I imagine the package will contain two components: a common package and a specific one;
curiously there are drivers for the MP210; not the 220 but drivers for the MP240, 250 and 260

  1. I see this:

Description: Canon MP220 series with driver Canon BJ-30 - CUPS+Gutenprint v5.0.2
Printer Driver: Canon BJ-30 - CUPS+Gutenprint v5.0.2
Printer State: idle, accepting jobs, published.
Device URI: usb://Canon/MP220%20series

2)Already tried official canon drivers for mp210 but unsuccessfully

Hi nedimm. I’ve seen several threads (Ubuntu-based) that suggest that the MP180 driver might compatible with your model. I also checked the openSUSE HCL which also suggests that the MP180 gutenprint driver is ok for your printer. So give it a try, and configure it via the CUPS web interface as pdc_2 already mentioned.

I type username and password but it isnt correct.Which username and password I need to use for localhost:631?

AFAIK, you need to use root user and password.

I tried but root username/pass combination doesnt work.

Not sure why your normal username and password doesn’t work. This thread may help:

printing cups/lppasswd - openSUSE Forums

Help with Printer - openSUSE Forums

This might help you if ur using 64 bit openSUSE. It worked for my Mp160 :slight_smile:

Now it works!
I added mp180 driver and everything works!

Thank you all for ideas

Thats great news! Glad I could be of assistance. :slight_smile: