Cannon MG 7150 on FRITZ!box not detected

Hello again,

On my freshly installed tumbleweed I‘d like to connect to my Canon MG 7150 multifunction printer. Whereas the printer is detected and installed, Tumbleweed does not detect the scanner. Usually I use xsane, which is installed. But yast keeps telling me that no scanner is detected.
To firewall I added ipp-client, mdsn and opened port 631 tcp and udp. I tried to stop the firewall as well to no success.
Can anybody help?

Hello again,

Maybe I should have mentioned, the printer is connected via a lan cable…

This port is not relevant to scanner discovery. Make sure ‘mdns’ is allowed in the firewall so that Avahi can discover the advertised device on the LAN.

Check what is returned by the following commands…

scanimage -L
avahi-browse -rt _uscan._tcp

Hello again,

Thank you for your message

I allowed mdns and sane in the home and public areas. And did the test with firewall stopped as well.

scanimage -L

Produces:

No scanners were identified.

avahi-browse -rt _uscan._tcp

Doesn‘t return anything.

On its own, that doesn’t mean much. It has to be applied to the zone in which the LAN interface is also included in.

Ok, I would expect the scanner to be detected if advertising via Bonjour (Avahi). It is listed here as being AirPrint compatible. I’m not sure if this discovery can be enabled or disabled from the device front-panel itself though.

Is the PC you’re trying to reach it from using Wi-Fi? Can you ping the device from the PC? Check host isolation (in the FritzBox) is not at play here.

Hello again,

I‘m sorry, I guess I should have been more precise. The printer is connected to the Fritz.Box via lan cable. The notebook connects to the Fritz.Box via WiFi.
By the way, in order to get the printer running, I have to use the cups web frontend (localhost:631). Yast will not detect the printer correctly The same is true for Almalinux where I have to stop the firewall and set SELINUX to permissive mode during detection. But after that procedure printer and scanner are detected on Almalinux.

Regards

That answers the first question. Please answer the second question, and also check the router host isolation (or similar).