Can’t grant Emby/Plex media (HDD) access permissions


I’m trying to setup my MediaServer software (Plex/Emby). I’m new to oST (though not to Linux) and I’m struggling to get this sorted out. I’ve had both running on Mint for years.

Goal: to setup & use Emby & Plex (both software apps are already installed and running)
Hurdle: give both programs/apps access to the media files (stored on external HDDs)

I have external hard drives formatted as exFAT and NTFS (I’m working on switching them all over to exFAT but not there yet).

I currently have my primary username set as the owner of the drives and the group is set to “users” (of which my user was the only member).

I used YaST to create a new group called mediaservers and I added Plex, Emby, and my user to this group. I thought that way, I could give the media server software access to the media files but not necessarily to any/everything else that my user group could access, if other things were owned by the group “users”.
I attempted to change the owner/user group to my newly created group, but it’s not working. On one drive, it appeared to work (when I changed it as my own user, not root - I didn’t get any error messages and it appeared to finish the job) but on other drives, I keep getting error messages saying that I don’t have the privileges to change some of the files. When I check those files, it’s showing that it’s owned by my normal user and group - so I don’t understand why I don’t have the privileges to change this or even what’s different about these files because the owner and group appear to be the same as all the other files on the drives. However, even the drive that appeared to work doesn’t “save” the new group. I even tried to change these as root and for the drive that appeared to work previously but didn’t “save”, I ended up with the same outcome and got the same error (not enough privileges) on the drive that had that error. Basically, exact same outcome when changing these as root.

So, I decided to take a different approach, desperate for something to work and instead of switching everything over to a new group, I added the Emby/Plex groups to my primary “Users” group that everything already belongs to. I’ve checked ls -l in the terminal to view all the drives and all user/group/other are correct and all have full rwx status. But, I still have no ability for Emby/Plex to even see the media/HDDs. I also used the terminal to look at the groups and see if Emby and Plex groups were added to my user group. They both were successfully but still have no access.

On a separate note, I currently have the drives mounted to the default location for external drives in oST/YaST (run/media/user/partition name). I looked into editing /etc/fstab and started by using YaST to do so (as was suggested by some other users). However, when use YaST to do this, nothing actually changes in fstab file (I’ve views it before/after to check and didn’t leave it opened while doing the edits in YaST to be sure that it was writable). Still no changes. Also, rebooting makes no difference on this either.

Please know, I’ve searched, I’ve read man pages and blog posts, and wikis etc. I’m just lost & so frustrated. I’m not usually this inept at figuring stuff out. But it’s not even making sense to me now why it’s not working. I’ve added the right groups to the group. So, I’m wondering if it’s because of how the disks are are mounted - though admittedly, that doesn’t make much sense either. I’m just desperate. I’ve spent several days on this now and I can’t figure it out. I don’t want to go back to Mint/Ubuntu and the like. But I don’t know why I’m having so many issues and why YaST doesn’t actually seem to be making any of the changes I’m trying to make. It’s the same with the user/group changes. It’s almost like I wasn’t using sudo in YaST but it definitely asked for my password. Please let me know what other info/data you need. Please help. I’m not unwilling to put in the work. I just don’t even know what that work should be at this point since these things that I thought should be successful aren’t.

Thanks so much in advance. Sorry for the wall of text. I just wanted to accurately cover what I’ve tried, what I’m attempting to do, and what hasn’t worked.