Can´t get to bios

Hi there

First of all I’m a noob in linux OS, I only have a basic knowledge about it, now the question

I’ve recently installed opensuse 11.0 on my sony vaio fz21e, after the installation I can´t get access to bios setup I’ve tryed all the combinations I’ve been using before (Del F1 F8 F10, etc) but nothing it goes straith to Grub, I guess I intalled it on the MBR the 1st sector of the harddrive, don’t know what to do…


There has to be a way to get to the BIOS no matter what you are loading, this is not the fault of GRUB. Perhaps you could search some Vaio forums to find the key that you need.

I think it’s the “del” key on that box; hit it repeatedly during the 1st few seconds of the boot.

BTW, there’s nothing wrong with having Grub on the MBR

“don’t know what to do” what are you trying to accomplish?

I recommend the time proven BIOS entry method:

Immediately after power on pres every possible BIOS entry sequence in as rapid succession as possible. Delete, F1, F8, F10, F11, escape, tab - everything.

The more frenzied you can press them the better. If you can imagine yourself as an insane conductor directing your own private orchestra by pressing the buttons it helps.

Magically BIOS will appear, as if conjured and drug unwillingly before you - commanded by your arcane powers to appear.

Seriously - you would be amazed how often this works.

Sure, there is the “magic button” - most likely F10 on that Sony? But jamming the buffer with crap works a lot of time too.

And Grub in the MBR is totally okay - best place for it.


Poor me (noob), I was blaming the suse,

I searched on sony foruns and guess what, there is a magical key wich I wasn’t trying… F2.

I was trying go get into bios to put the usb stick in priority to boot, because I’m trying to run a live cd from a usb stick, so I ran wihout errors on suse to create a MBR on the stick and then when I reboot, it couldn´t boot from the usb stick and I’ve tryed all my usb ports any ideas?


You tried unetbootin? It’s free, easy, and apparently cross-platform.

If you’re trying to install via USB, rather than create a live stick, try this…

EeeUser ASUS Eee PC Forum / openSUSE onto SDHC without CD drive -> STUCK!