can' t find mach_kernel

Good evening.After a cut in my house’ s power supply (the pc was working),i got the title message when i tried to boot into suse (12.1).Any ideas?

I have never seen such an error message before in Linux. Searching on “can’ t find mach_kernel” seems to bring up topics for Mac or Apple computer booting. Can you tell us any more than you have so far?

Thank You,

Problem solved.You are right,the name brings to mind a mac system.I have a dual boot system in which i added the linux (suse) entry through easybcd (a program that runs in windows in which you adjust which os you have,boot order etc).So i added the linux entry again and it worked.I hope i do not have to do that everytime the power cuts off.

Let me add that a UPS (around $100 US) can prevent such problems in the future. I have added one to my system since I had a power failure last year and had to reload openSUSE. It is a very common problem for desktops and a UPS of some sort is the only real solution for it. Power failures do occur when you least expect. I prefer the APC brands and use them at work and at home, highly recommended and Linux drivers exists for most APC models.

Thank You,