Can´t boot in to normal desktop mode.


so i´ve got a new notebook- HP Pavilion g7 with AMD Radeon HD 8670 M/ Intel graphics stuff. I am newcomer in to OpenSuse world. For first, i disabled everything about secure boot in BIOS and tried KDE version of OpenSuse, bit it didn´t boot in to live enviroment- it just stoped at the splashscren and nothing was happening for 20 min, so i gave up. Then i tried OpenSuse DVD and… yes, it booted in to installation process. I tried " use an entire disk" and also “recommended settings” and in bootloader settings i tried GRUB2-EFI with secure boot support and GRUB 2. In every case, installation went ok, system restart and in boot screen i chose Open Suse 13.1. What happened was some sort of configuration screen ( after splash screen with chameleon) where was some information with green OK status. First thing- it failed to activate SWAP eihter SWAP was on sda2 or sda3, but everything else was ok. Configuration process stops at permit user session(?) with OK status. After that, i tried to go in to recovery mode- when i pressed enter on “recovery” mode in bootloader, some sort of installation process looking like classic installation starts with text " Previous installation wasn´t succesful, do you want to reconfigure it?" I did insert DVD and pressed OK- then there was automatic configuration process going and at the end I finally went in to recovery mode. Nice and fast, beautiful plasma desktop- with no networking. I tried to connect to home wifi and it acted like i am connected, but after trying to go to web, it was disconnected again. I was clueless and for fun tried again restart- normal desktop mode and again, it was stuck and permit user session with ok status… i waited for 5 minutes and finally- normal mode started with…no networking. I did restart and tried again normal mode and- nothing, just black screen ( 15 minutes nothing) and that´s it. I don ´t know what to do. Note: i tried another distributions and only Ubuntu 12.04.3 is working out of the box, even new 13.10 isn´t working ( low graphic mode), Fedora doesn´t even boot ( bash-like line editing tool prompt), netrunner and Kubuntu have problems with grub-efi- signed amd64 and i really don ´t want to get stuck only with Ubuntu 12.04 and no way i am going to install Windows… so please, help… some tips… or something.

This is probably a video problem with your hybrid intel/radeon chips. There are known solutions (bumblebee) for intel/nvidia hybrids. I don’t know about intel/radeon hybrids

Try this at boot screen press e then find line starting with linux go to end (press end key) and enter a space and nomodeset. Then press F10 to continue boot.

Note this is not permanent but if it works we may be able to formulate a work around

I found it and typed nomodeset and after F10 it was doing configuration instead of blackscreen but it stucked with OpenSuse Firewall phase 2… after 10 min. still nothing…

There has been a problem with network/internet in previous versions of openSUSE,
which could be solved by simple re-booting, as far as I remember.

Don’t think that is the problem here

Corrupt install disk or ISO maybe??

Also the radeon/intel GPU combo is new to me

YAF (Yet Another Frankenvideo)

I tried USB and DVD with new downloaded iso from website. I am out of ideas on my own… probably going to stuck with Ubuntu 12.04 and I´ll be waiting till some changes in kernel happens… or something. That´s the thing which bugs me, old 12.04 is working out of the box and new versions of any distributions just doesn´t work. Thanks guys for helping me.