Can`t add torrent files to Deluge


I can`t figure out how to add torrent files to deluge- all the settings are greyed out. When I start deluge i get an error message:

/usr/lib/python2.5/site-packages/deluge/ui/gtkui/ GtkWarning: Failed to set text from markup due to error parsing markup: Fehler in Zeile 1, Zeichen 29: Element »markup« wurde geschlossen, aber das derzeit offene Element ist »b«

(deluge:14143): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

I`m running OS 11.0/Gnome. Any idea how to fix this ? Thanks

Don’t use it
Get transmission it’s much better
it’s in Packman

I`d love to but Transmission is banned on one of the trackers i use…

How about telling us what you can use

What about vuze/azureus

I can use everything except Transmission because it seems to mess up your ratio. Bittornado works great but needs a lot of ram. If i can`t fix deluge i guess i just keep using Bittornado. Is Deluge really that bad ?

are you using the Packman version?

Yes, I got it via yast. I`m running 1.2.0-rc4, the latest release is 1.2.0-rc5. There is no upgrade available for suse 11.0.

The Packman packaged Deluge does work on a 32-bit openSUSE-11.2 with Gnome. I have it running on my Sandbox PC. But I’m no expert with it. I installed it (from Packman) and it “just worked”.

I have no idea why you can’t add torrent files. I assume you selected a place to add them where you have write permissions?

What about Monsoon, did you try that?

I use Vuze and never have problems with it. And it’s not as hungry as some make out - not for me anyway.

I just took a screenshot, as you can see the toolbar and the settings are greyed out.](

I do not see that.

This is what I see on my Sandbox PC during a test:](

The OP is in OS 11.0
If that matters Lee.

There are loads of torrent clients out there, so plenty of choice.

Yes, it may matter that the OP has 11.0. … and it may not.

IMHO The problem could be

  • a packaging problem by Packman, or
  • that the OP has added many different repostories to their OpenSUSE-11.0 and installed an app that has broken Deulge, or
    *]a simple Deluge setting, that I can’t help with because Deluge “just worked” for me and I did not have to setup anything. It simply just worked.

I just installed flush, seems to work. Thanks for your help oldcpu and caf4926.

Glad to read that a fresh re-install worked for you.

No, flush is a bittorrent client. :slight_smile:

Flush | Get Flush at

The developer told me to install twisted-web & Deluge works fine now.

Interesting. Thanks for sharing your solution. But its fuzzy to me.

I do not know of an openSUSE packaged rpm called ‘twisted-web’. I do note there is a Packman and OSS package called “python-twisted-web” which I do NOT have installed and my deluge works!

I also note there is an OSS package called ‘python-twisted’ which I DO have installed. Could it be that ‘python-twisted’ package you are referring to and not some package called ‘twisted-web’?

The package is called “phyton-twisted-web”. The Delude package for 11.2 may be different, i guess there are some minor differences between 11.0 and 11.2.

On 12/29/2009 09:46 AM, quimby123 wrote:
> The package is called “phyton-twisted-web”. The Delude package for 11.2
> may be different, i guess there are some minor differences between 11.0
> and 11.2.

The question is: How did you install “deluge” in the first place?

through ‘YaST’ or ‘zypper’?

I’ve just installed ‘deluge’ with ‘yast’ and got a slew of dependencies,
some of them quite big. I’m on openSUSE 11.2.

rpm -q deluge