Can run game as root but not as regular user

Hello,

I am able to launch a game (sauerbraen) only if I’m logged in as root in a terminal. If not, there is a crash with the following trace (full traces below) :

libGL error: open uki failed (Operation not permitted)

I was unable to find anything about that error on this forum or on Google. Can anyone help? Thanks!

As root (no crash) :

linux-wbq1:~ # sauerbraten
init: sdl
init: enet
init: video: mode
init: video: misc
init: gl
Renderer: ATI Radeon HD 4200 (ATI Technologies Inc.)
Driver: 3.2.9551 Compatibility Profile Context
WARNING: ATI cards may show garbage in skybox. (use "/ati_skybox_bug 1" to fix)
WARNING: Using floating point vertexes. (use "/floatvtx 0" to disable)
Rendering using the OpenGL 1.5 GLSL shader path.
WARNING: Disabling occlusion query on ATI's fglrx driver to avoid crashes.
WARNING: No occlusion query support! (large maps may be SLOW)
GLSL ERROR (VS:nocolorglsl)
Vertex shader was successfully compiled to run on hardware.

GLSL ERROR (PS:nocolorglsl)
Fragment shader was successfully compiled to run on hardware.
GLSL ERROR (VS:glsltest)
Vertex shader was successfully compiled to run on hardware.

GLSL ERROR (PS:glsltest)
Fragment shader was successfully compiled to run on hardware.
init: console
init: world
init: sound
init: cfg
init: localconnect
init: mainloop
read map packages/base/metl4.ogz (0.0 seconds)
Mining Station by metlslime
game mode is ffa/default

As regular user (crash) :

ben@linux-wbq1:~> sauerbraten
init: sdl
init: enet
init: video: mode
libGL error: open uki failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
init: video: misc
init: gl
Renderer: ATI Radeon HD 4200 (ATI Technologies Inc.)
Driver: 1.4 (3.2.9551 Compatibility Profile Context)
WARNING: No vertex_buffer_object extension! (geometry heavy maps will be SLOW)
WARNING: ATI cards may show garbage in skybox. (use "/ati_skybox_bug 1" to fix)
WARNING: Using floating point vertexes. (use "/floatvtx 0" to disable)
Rendering using the OpenGL 1.5 assembly shader path.
WARNING: Disabling occlusion query on ATI's fglrx driver to avoid crashes.
WARNING: No occlusion query support! (large maps may be SLOW)
init: console
init: world
no such shader: stdworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpparallaxglowworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpparallaxglowworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapglowworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapparallaxworld
no such shader: stdworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: stdworld
no such shader: stdworld
init: sound
init: cfg
init: localconnect
init: mainloop
read map packages/base/metl4.ogz (0.1 seconds)
Mining Station by metlslime
no such shader: stdworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpparallaxglowworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpparallaxglowworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapglowworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapparallaxworld
no such shader: stdworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapworld
no such shader: bumpspecmapparallaxworld
no such shader: stdworld
no such shader: stdworld
no such shader: stdworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpparallaxglowworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpparallaxglowworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpparallaxglowworld
no such shader: bumpspecmapparallaxglowworld
no such shader: bumpspecmapparallaxworld
no such shader: bumpspecmapparallaxglowworld
game mode is ffa/default
X Error of failed request:  GLXBadRenderRequest
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  1 (X_GLXRender)
  Serial number of failed request:  3973
  Current serial number in output stream:  3976

Hello oysterboy,

I’m not sure but maybe you need to be member of the group games.
Go to Yast->Security And Users->User and Group Management.
Select your user and click on edit. Go to the tab “details”.
On the right you’ll see a list with “Additional Groups”.
Select the games group and click OK.

Good luck!

Hmmm… Seemed like a good idea but it didn’t work. Currently I’m only member of the ‘users’ group. Becoming member of every possible group didn’t help either.

Hello again oysterboy,

Sad to hear it didn’t work.:frowning:
Have you tried it with other users.
You could try making a test user and run the game.
If the game runs it is most likely a wrong setting in your other user.

And can you also tell us how you installed it.
Did you use a package? Compiled it from source?

Best of luck!

Hello Edward,

It worked with a test user !! The test user is member of the users and video groups. I made sure my user is also member of those two groups, but I still cannot launch the game :(.

To answer your question, I installed the game from the ‘Games’ repository (Index of /repositories/games/openSUSE_11.2).

Hello oysterboy,

It worked with a test user !!
That’s good news!:slight_smile:
Can you show us the output of the test user?

I made sure my user is also member of those two groups, but I still cannot launch the game :(.
Now it’s almost certain that it’s a wrong setting in your user.

But there’s still a slight chance that the problem has something to do with your Xorg configuration.
Can you show us the file “/etc/X11/Xorg.conf”?

Good luck!:wink:

gwen@linux-wbq1:~> sauerbraten
init: sdl
init: enet
init: video: mode
init: video: misc
init: gl
Renderer: ATI Radeon HD 4200 (ATI Technologies Inc.)
Driver: 3.2.9551 Compatibility Profile Context
WARNING: ATI cards may show garbage in skybox. (use "/ati_skybox_bug 1" to fix)
WARNING: Using floating point vertexes. (use "/floatvtx 0" to disable)
Rendering using the OpenGL 1.5 GLSL shader path.
WARNING: Disabling occlusion query on ATI's fglrx driver to avoid crashes.
WARNING: No occlusion query support! (large maps may be SLOW)
GLSL ERROR (VS:nocolorglsl)
Vertex shader was successfully compiled to run on hardware.

GLSL ERROR (PS:nocolorglsl)
Fragment shader was successfully compiled to run on hardware.
GLSL ERROR (VS:glsltest)
Vertex shader was successfully compiled to run on hardware.

GLSL ERROR (PS:glsltest)
Fragment shader was successfully compiled to run on hardware.
init: console
init: world
init: sound
sound init failed (SDL_mixer): No available audio device
init: cfg
init: localconnect
init: mainloop
read map packages/base/metl4.ogz (0.1 seconds)
Mining Station by metlslime
game mode is ffa/default

# /.../
# SaX generated X11 config file
# Created on: 2010-02-26T22:23:50-0500.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [SaX2] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
	Identifier     "Layout[all]"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	InputDevice    "Keyboard[0]" "CoreKeyboard"
	InputDevice    "Mouse[1]" "CorePointer"
EndSection

Section "Files"
	InputDevices   "/dev/gpmdata"
	InputDevices   "/dev/input/mice"
	FontPath     "/usr/share/fonts/misc:unscaled"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/75dpi:unscaled"
	FontPath     "/usr/share/fonts/100dpi:unscaled"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/URW"
	FontPath     "/usr/share/fonts/Speedo"
	FontPath     "/usr/share/fonts/PEX"
	FontPath     "/usr/share/fonts/cyrillic"
	FontPath     "/usr/share/fonts/latin2/misc:unscaled"
	FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
	FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
	FontPath     "/usr/share/fonts/latin2/Type1"
	FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
	FontPath     "/usr/share/fonts/baekmuk:unscaled"
	FontPath     "/usr/share/fonts/japanese:unscaled"
	FontPath     "/usr/share/fonts/kwintv"
	FontPath     "/usr/share/fonts/truetype"
	FontPath     "/usr/share/fonts/uni:unscaled"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/ucs/misc:unscaled"
	FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
	FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/misc:unscaled"
	FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/Type1"
	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
	FontPath     "/usr/share/fonts/xtest"
	FontPath     "/opt/kde3/share/fonts"
EndSection

Section "Module"
	Load  "dri"
	Load  "dbe"
	Load  "extmod"
	Load  "glx"
EndSection

Section "ServerFlags"
	Option	    "AllowMouseOpenFail" "on"
	Option	    "ZapWarning" "on"
EndSection

Section "InputDevice"

  # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section. 
	Identifier  "Keyboard[0]"
	Driver      "kbd"
	Option	    "Protocol" "Standard"
	Option	    "XkbLayout" "us"
	Option	    "XkbModel" "microsoftpro"
	Option	    "XkbRules" "xfree86"
EndSection

Section "InputDevice"

  # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section. 
	Identifier  "Mouse[1]"
	Driver      "mouse"
	Option	    "Buttons" "5"
	Option	    "Device" "/dev/input/mice"
	Option	    "Name" "Generic USB K/B"
	Option	    "Protocol" "explorerps/2"
	Option	    "Vendor" "Sysp"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "Modes"
	Identifier     "Modes[0]"
	ModeLine     "1680x1050" 144.6 1680 1784 1968 2256 1050 1051 1054 1086
	ModeLine     "1680x1050" 115.0 1680 1728 1760 1840 1050 1053 1059 1079 +hsync -vsync
	ModeLine     "1280x1024" 138.5 1280 1368 1504 1728 1024 1025 1028 1069
	ModeLine     "1280x1024" 128.9 1280 1368 1504 1728 1024 1025 1028 1066
	ModeLine     "1280x1024" 119.4 1280 1368 1504 1728 1024 1025 1028 1063
	ModeLine     "1280x1024" 113.0 1280 1328 1360 1440 1024 1027 1034 1061 +hsync -vsync
	ModeLine     "1280x1024" 108.9 1280 1360 1496 1712 1024 1025 1028 1060
	ModeLine     "1280x960" 129.9 1280 1368 1504 1728 960 961 964 1002
	ModeLine     "1280x960" 120.8 1280 1368 1504 1728 960 961 964 999
	ModeLine     "1280x960" 111.0 1280 1360 1496 1712 960 961 964 997
	ModeLine     "1280x960" 105.8 1280 1328 1360 1440 960 963 967 994 +hsync -vsync
	ModeLine     "1280x960" 102.1 1280 1360 1496 1712 960 961 964 994
	ModeLine     "1152x864" 105.0 1152 1224 1352 1552 864 865 868 902
	ModeLine     "1152x864" 96.8 1152 1224 1344 1536 864 865 868 900
	ModeLine     "1152x864" 89.6 1152 1224 1344 1536 864 865 868 897
	ModeLine     "1152x864" 86.8 1152 1200 1232 1312 864 867 871 895 +hsync -vsync
	ModeLine     "1152x864" 81.6 1152 1216 1336 1520 864 865 868 895
	ModeLine     "1024x768" 81.8 1024 1080 1192 1360 768 769 772 802
	ModeLine     "1024x768" 76.2 1024 1080 1192 1360 768 769 772 800
	ModeLine     "1024x768" 69.7 1024 1080 1184 1344 768 769 772 798
	ModeLine     "1024x768" 69.5 1024 1072 1104 1184 768 771 775 796 +hsync -vsync
	ModeLine     "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795
	ModeLine     "800x600" 48.9 800 840 920 1040 600 601 604 627
	ModeLine     "800x600" 45.5 800 840 920 1040 600 601 604 625
	ModeLine     "800x600" 44.0 800 848 880 960 600 603 607 622 +hsync -vsync
	ModeLine     "800x600" 42.1 800 840 920 1040 600 601 604 623
	ModeLine     "800x600" 38.2 800 832 912 1024 600 601 604 622
EndSection

Section "Monitor"
	Identifier   "Monitor[0]"
	VendorName   "GSM"
	ModelName    "LG ELECTRONICS W2254"
	UseModes     "Modes[0]"
	DisplaySize  474	296
	HorizSync    30.0 - 83.0
	VertRefresh  43.0 - 75.0
	Option	    "DPMS"
	Option	    "PreferredMode" "1680x1050"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "Device[0]"
	Driver      "radeonhd"
	VendorName  "ATI"
	BoardName   "ATI Radeon HD Graphics"
	Option	    "monitor-DVI-D_1" "Monitor[0]"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "Screen[0]"
	Device     "Device[0]"
	Monitor    "Monitor[0]"
	DefaultDepth     24
	SubSection "Display"
		Virtual   3840 1200
		Depth     15
		Modes    "1680x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Virtual   3840 1200
		Depth     16
		Modes    "1680x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Virtual   3840 1200
		Depth     24
		Modes    "1680x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Virtual   3840 1200
		Depth     8
		Modes    "1680x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Group        "video"
	Mode         0660
EndSection

I also found something : the output of fglrxinfo is different

My user :

ben@linux-wbq1:~> fglrxinfo
libGL error: open uki failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4200
OpenGL version string: 1.4 (3.2.9551 Compatibility Profile Context)

The test user :

gwen@linux-wbq1:~> fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4200
OpenGL version string: 3.2.9551 Compatibility Profile Context

Hello oysterboy,

Looking at you Xorg.conf file I see that the DRI section has mode set to 0660.
Try changing it to:

  Mode 0666

This will allow every user in the group video to use DRI.
But be carefull!!! Before you change it make a backup of Xorg.conf.
And when you chance it make sure that you restart the Xserver afterwards (Hit Ctrl+Alt+Backspace twice).

And have you changed openGL/Xorg recently?

Best of luck!

Hello Edward,

Problem solved :). I reboot the computer and everything works fine with my user. I think the only change I made was to add my user to the video group, just like the new test user.

Thanks a lot for your help :slight_smile: !

Hello oysterboy,

I think the only change I made was to add my user to the video group, just like the new test user.
This probably solved it. User changes only take effect when you log out and log in again. (Sorry forgot to tell you)
This also happens when you reboot the system.

For people who have the same problem make sure to add your user to the group video.
And log out and log in again.

Thanks a lot for your help :slight_smile: !
No thanks.