Can only write NTFS as root


After the fresh installation of openSUSE 11.4 x64 (Gnome 2.32.1) my NTFS drives were mounted automatically. However, I can only write those partitions as root. I’ ve already tried everything I found on the internet, but none of those solutions worked and as a rookie, I haven’t got any idea how to proceed.

My original FSTAB looked like this:

/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part6 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part7 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part8 /home                ext4       acl,user_xattr        1 2
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part2 /windows/c           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part3 /windows/d           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

Then I changed the relevant lines to these:

/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part2 /windows/c ntfs-3g defaults 0 0
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part3 /windows/d ntfs-3g defaults 0 0

But it hadn’t done the trick, so I dug deeper and changed those lines to:

/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part2 /windows/c ntfs-3g    uid=1000,gid=100,umask=0022    0 0
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part3 /windows/d ntfs-3g    uid=1000,gid=100,umask=0022    0 0

Then to:

/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part2 /windows/c ntfs-3g    uid=suzette,gid=users,umask=0022    0 0
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_100708PBN403B7HMV4WL-part3 /windows/d ntfs-3g    uid=suzette,gid=users,umask=0022    0 0

I also installed ntfs-config and according to it my drives are supposed to be writeable (although that might refer to my root account).

But none of the above steps made my NTFS partitions writeable for a non-root account.

I restarted my system after each time I changed the content of FTSAB.

Could anyone help?

Change this users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 into defaults and try again.

Edit: see this is your first post. Welcome to the forums. While this is asked here many times (and you could have find them by searching) we still will try to help you.

Thanks Henk, but that was the first thing I tried, because in any other case that fixed the problem (I checked many sites before posting).

However, now the problem is solved. The problem was that I checked if I can write on the partition every time by trying to delete a file, and there always was an error message that “Unable to find or create wastebasket directory” so I figured I cannot write the partition at all. But before giving up, I tried to copy a file from my home partition to one of my NTFS drives and to my biggest surprise it worked.

So I googled the error message instead of the writing issue and found the solution. I had to change the original users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 line into defaults,umask=077,uid=1000.

Now it works and I learned my lesson: google the error message not what I believe the problem is :slight_smile:

Nice you solved it. I take the liberty to make a few remarks.

. When you found allready out that the most obvious solutions (you found manifold on these forums and elsewhere) did not help you, please say so. Most of us are not clairvoyant and saying you tried things may avoid people taking the effort to answer with things you allready know.

. I think that what you call “trying do delete a file” is not deleting at all. Deleting a file is done with

rm <filename>

and variants. I assume you used some GUI tool. Those are nice for day to day work for end users, but not for real testing of the system by the system manager. Allways try to remove as many layers as possible between you and the system when analyzing problems. It will also help in you not “believing”, but checking the root cause.

. Maybe superfluous, but never forget that NTFS (and (V)FAT) file systems are non-native Linux systems. They lack features that Linux file systems have. Their usage is possible in Linux, but must have some emulation and other tricks. Thus it is fine to use them for e.g. exchanging with systems where these file systems are native, but there are restrictions and you better never use them as full fledged file systems instead native Linux file systems for normal Linux work.

Enjoy openSUSE.

On 2011-05-16 21:06, hcvv wrote:
> Nice you solved it. I take the liberty to make a few remarks.
> When you found allready out that the most obvious solutions (you
> found manifold on these forums and elsewhere) did not help you, please
> say so.

But he did… I see them in the first post. :slight_smile:

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Correct, I appoligize :shame: