Can not update due to "removal of plasmoid-networkmanagement" freezes

I recently installed Suse-13.1 on my “12 processors + 32 GB RAM + GTX 580 nvidia graphic card” computer using kde-live CD.

  1. The installation is not perfect since many applications crash/freeze resulting into system freeze.

  2. The problem seems to be related to display management. There is no nvidia driver in the system at the moment.

  3. In my earlier trials I could not install nvidia driver successfully and the attempt resulted to install the OS again formatting the existing one.

  4. Now, the desktop looks fine with the live-cd installation but it is still not perfect and has this display crash issue.

  5. I am planning to update things one by one this time. And first step is “zypper patch”.

  6. The update can’t proceed since it always freezes at this action:
    “Removing plasmoid-networkmanagement-…”

Can somebody please help me to update my system and eventually get nvidia driver working for me.


First off install the NVIDIA driver. You did not say how you tried before did you do it with a one click?

That page covers all the ways it should be done.