Can not type my password into some of the "authentication required" boxes

I am using Tumbleweed, xen, Dom0 kernel, KDE plasma desktop on 3 monitors.

Sometimes, when I am required to e.g. connect to Xen in the virtual machine manager, the box appears “Authentication required” with the place to enter root password. The trouble is that I can not enter the password. When I place the cursor in the box and type anything, the symbols hiding the password just do not appear.
I updated whole system, no help. I ran “zypper dup” and I went to a pain of reinstalling it all. No help. The problem appears even when the regular (non Xen) kernel is booted.

Some places (such as staring Yast) allows me to enter the password with no problems. Some places allow me to type characters with huge delay. Like I press a character, and corresponding symbol appears only after multiple presses, after several (~15) seconds.

What do I do? How do I troubleshoot it?

Nothing interesting in the log obtained by journalctl -b

Some place like su do not echo keystrokes. Are you sure that you are not actually entering the password??

Yes, I am sure, because:

  1. Sometimes a character appear after I press a button like 40 times
  2. When I type my password elsewhere (e.g. in the browser search line), copy it, left click on the password field selecting it, the right-click - paste, full number of the characters in my password appear and it is accepted by the system. In fact that’s the only way I found to get past it.
  3. If I pretend to continue typing (although no characters appear) and press “OK” button the empty password is, of course, rejected.

su from the terminal works just fine. I am concerned with the graphical su, whatever the right term is.

There was a thread on this forum dedicated to similar problem, I just can not find it.

Same thing happens when I go to the network manager to configure settings. But getting into, say, Yast is fine

This is not kdesu, this is some other tool. kdesu works perfectly fine.

Can you post a screenshot?
I’ll be happy to keep the image inside a post, but shame on me as I am unable to find attach button in the post editor >:(

Is the right keyboard activated? Test it anywhere else: Shell, LibreOffice, …
Is the application right configured?

Is the right keyboard activated?
Yes. This is a laptop with built-in and attached USB keyboard. Both keyboards work elsewhere: Shell, Kate, … Both keyboards have the same type of problem with “authentication required” dialog boxes.

s the application right configured?
Please, elaborate. This behavior is exhibited with at least 2 applications: Virtual Machine Manager and Network Manager.

Looks like it is a policykit window. But still not clue on how to fix it.

AFAICS it is indeed. It looks like your user doesn’t have access. Could it be you’re missing a group membership?

IMO any person who posts about a TW problem has to provide the version (last dup).

This can be returned by running the following in a console

cat /etc/os-release


NAME="openSUSE Tumbleweed"

# VERSION="20160831"
PRETTY_NAME="openSUSE Tumbleweed"

Bug seems to be specific to plasma5. Plasma desktop, gnome are prone to this bug.

You might try upgrading again and see if the problem is resolved.

Just upgraded my TW and the current version as of today is 20160911.


Latest update made the things even worse. No I can barely type even in “ALT+space” command line …