Can not switch off the desktop effect on Suse 11


I was playing around with the XGL desktop effects on the SuSE 11. I enabled the effect by Simple Compiz Config Setting Manager found in application/utilities/desktop/Desktop Effects. The decoration seems to block the close, maximize and minimize button on the window title bar. I tried to switch the desktop effects off. Each time it seems to be turned off but comes back on the next logon. Is there any way I can manually switch these effects off like the

gnome-xgl-switch --disable-xgl

would do the trick? Since SUSE 11 gets new way of setting up XGL, I am not sure if I should still use the old way to do it. The GUI suppose to work. Is it a bug?

I used to toggle the XGL using
1/ xgl-switch --enable/disable-xgl (in console with no graphics)
2/ In KDE there is an icon called “Desktop effects”. It can be found by search in the “Start” menu. You should use it to enable/disable certain visual effects.

In your case that would be first 2/ and then 1/.
Good luck.

Thanks. I tried option 2 many times and not working for me. It the XGL effects just came back by itself.

The option 1 gave me this

Warning! MD5DIR is not set: you probably called this script outside SuSEconfig…!
Using MD5DIR="/var/adm/SuSEconfig/md5"…
No changes for /etc/X11/xdm/Xservers
No changes for /etc/X11/xdm/xdm-config

It doesn’t seems to be working either

Now, I’m faced with the same error message as sueyentsai. I can’t switch off compiz. Any ideas?

I just had this problem.
Enabled XGL on a system w/ a bad video card. All I got was a white screen which I could rotate via the cube plugin. I ran the ‘xgl-switch --disable-xgl’ command as root and noticied that it still didn’t work for my regular user. Ultimately, I deleted the ‘compiz’ directory under my ~/.config/ directory. That allowed me to get back into gnome as my regular user. I realized that this must have been a problem since I was still able to get into X as root just fine.

in summary,
try running the ‘xgl-switch’ command AND delete the ‘compiz’ directory under ~/.config.


A while ago there was a bug in which KDE would not remember between login sessions that desktop effects had been switched ON. They fixed that. Now it won’t remember that they’ve been switched OFF.

(me too)

Log in as root. Navigate to your home directory. If there’s a folder named Compiz in the .config(hidden) directory, delete it. Log out root and back in as you. Desktop effects should be disabled.

BAD advice NEVER log in as root use su or sudo instead

In a console type su then your root password then
**xgl-switch --disable-xgl **(to disable Xgl and deactivate Compiz)

Have a read here

This is assuming he can see a console or anything but a blank monitor with his user login.
…though, I suppose he could do a console login from KDM.

the desktop effect seems to be very tough to kill. I tried the sudo xgl-switch --disable-xgl as well as remove the compiz folder under the .config under my home folder. The next time I logon, the compiz grew back by itself:O

The desktop effect is still there. Actually I don’t necessary have to remove it. Just the windows decoration thing is blocking all the maximize, minimize and close icon. I have to guess where it is and hit the right spot to get those buttons functioning. If there is a way to have them show up all the time. That would be good enough.

Not similar, but perhaps related problem, my openSuSE 11 gnome system just lost its desktop - never to be found again! Just black screens and attempts to recreate it with icons and all dont seem to succeed. I will experiment more tonight, but any guidance would be appreciated.

According to the release notes, you can no longer user gnome-xgl-switch to enable/disable XGL - only the command line utility is left.

Have you tried running simple-ccsm and and unchecking ‘Enable Desktop Effects’ ? Does it seem to do anything (screen flicker, etc when you check/uncheck it)?

This may be late in coming … but you will need to :

open Configure Desktop/Advanced Tab/Session Manager/select Kwin in the Window Manager section

in kde go 1)sys config 2)default app 3)Window manager 4)use kwin
et voila!

ok ok i forgot: what i gave your in for kde4.1

gee!! finger prbls on my side…

I have too the same problem.

Unchecking ‘Enable Desktop Effects’ works, but after you reboot, the Desktop Effects come back.


  • Window Decorator: GTK Window Decorator (and tried with Auto)
  • Window Manager: Metacity

EDIT: I don’t know if there is a relation, but I keep getting this type of message in /var/log/messages:
gconfd (heldwin-3955): “Resolved address “xml:readwrite:/home/heldwin/.gconf” to a writable configuration source at position 0”

Forget the edit, it was Pulse Audio related (user was not in pulse-rt and pulse-access groups).

Deleting ~/.config/compiz/enable-compiz, fix the problem, but if I reactivate it using simple-ccsm, the problem returns.

If I open simple-ccsm in a terminal, I see this error when I uncheck ‘Enable Desktop Effects’ :

Traceback (most recent call last):
File “/usr/bin/simple-ccsm”, line 1295, in EnableDesktopEffectsChanged
File “/usr/lib/python2.5/”, line 594, in init
errread, errwrite)
File “/usr/lib/python2.5/”, line 1147, in _execute_child
raise child_exception
OSError: [Errno 2] Aucun fichier ou dossier de ce type

I am using Gnome, and the line 1295 in simple-ccsm is:

Reset window manager config for KDE

cmd = “kwriteconfig --file ksmserverrc --group General --key windowManager kwin”.split(" ")

EDIT: Commenting these 2 lines fixed the problem.

For the fun, changed them to this, using the line for activation:

Disable compiz in kde

try:‘kwriteconfig --file ksmserverrc --group General --key windowManager kwin’.split())
except (IOError, OSError):

It should work, no ?
(I don’t have KDE installed to test it :slight_smile: )