Can not setup printer


Newbie to SUSE. I am running Tumbleweed. I am trying to connect and setup a wireless printer, a HP Envy 7500. The printer functions fine with machines running Win10, Ubuntu 18.10, and a Chromebook. When I go to the Add a New Printer - Add printer, I enter my user password in the popup box and it seems to search for a moment and then I get a Failed to get List of Devices:‘Forbidden’ error.

Do I need to set up a Root account? I do not remember being asked for root user during setup. If I do need root, how do I set up the root user after install?

Than you for your help!

First, welcome to openSUSE Forums. From your comments above, I’m speculating that you may have a root account using the same password credentials as your user account (configured that way when you first installed TW), so try using ‘root’ and the user password first. There are ways to fix that if you really can’t remember it though…


Sorry it took so long to get around to actually dealing with the issue.

But thank you for the help! You were spot on correct about needing to regain root access. I now have the printer working correctly.

There is much I need to relearn about enhanced security after running Ubuntu for so many years. So far I’m enjoying the new environment and looking forward to seeing how well the rolling release fits me.

Again Thank you!

Edit to add: Is there a way to mark this post Solved?

Glad to have been of assistance. We don’t generally mark threads as solved here (although you can edit your thread title when you reply to mark it as such if you wish).