Can not open or browse NTFS partition in Suse

I’m running openSUSE 11.2 (KDE 4.4.0) on an Lenovo Thinkpad SL500 2746 4EG, dualboot with Windows 7 and I cant open my NTFS partitions from openSUSE, it doesn’t show any available space, and when i click on the device to access it nothing happens. Then i right-click - open in new tab and it opens a “Open with” window. What should I do to get access to my NTFS partitions ?
Thanks

M4rek wrote:
> I’m running openSUSE 11.2 (KDE 4.4.0) on an Lenovo Thinkpad SL500 2746
> 4EG, dualboot with Windows 7 and I cant open my NTFS partitions from
> openSUSE, it doesn’t show any available space, and when i click on the
> device to access it nothing happens. Then i right-click - open in new
> tab and it opens a “Open with” window. What should I do to get access to
> my NTFS partitions ?

http://lmgtfy.com/?q=opensuse+ntfs
http://en.opensuse.org/NTFS

For more help, give more information.
The relevant line in /etc/fstab would be interesting as well as any
kernel messages when you mount the file system. Common errors include
trying to mount a dirty filesystem (run file system check under Windows)
and misconfigured permissions, see uid,gid,umask,fmask.dmask options.
“man mount” explains all mount options.

With kind regards,
Andreas Stieger

M4rek wrote:
> I’m running openSUSE 11.2 (KDE 4.4.0) on an Lenovo Thinkpad SL500 2746
> 4EG, dualboot with Windows 7 and I cant open my NTFS partitions from
> openSUSE, it doesn’t show any available space, and when i click on the
> device to access it nothing happens. Then i right-click - open in new
> tab and it opens a “Open with” window. What should I do to get access to
> my NTFS partitions ?

http://lmgtfy.com/?q=opensuse+ntfs
http://en.opensuse.org/NTFS

For more help, give more information.
The relevant line in /etc/fstab would be interesting as well as any
kernel messages when you mount the file system. Common errors include
trying to mount a dirty filesystem (run file system check under Windows)
and misconfigured permissions, see uid,gid,umask,fmask,dmask options.
“man mount” explains all mount options.

With kind regards,
Andreas Stieger

I tried to mount one of windows partitions, but unsuccessfuly.

I added one line to the etc/fstab, after linux partitions:
/dev/sda1 /Preload/C ntfs-3g user,users,gid=users,umask=0002 0 0

But I am not sure whether Mountpoint is correct (/Preload/C). That partition in Windows is called “Preload” and it is marked with “C”

Here is screen from Partitioner … you can see my partitions:
http://i50.tinypic.com/295zfwg.png

And I ran System Files Checker in Windows, everything is correct.

Typically openSUSE will automount NTFS drives in read-only as part of the Installation setup. Such a mount will fail (as noted above) if the drive is dirty. Please boot to ms-windows and run a chkdsk against the ntfs drive (while in windows). And then shut down ms windows properly, do NOT hibernate as Linux will not read/write an ms windows drive that is hibernated.

Once you obtain the capability to read the drive contents, we can sort out how to write to an ntfs drive.

Please provide the output of running:

cat /etc/fstab
df -Th
su -c 'fdisk -l'

enter root password when prompted for a password

I wrote this to the fstab:

/dev/sda1 /mnt ntfs-3g user,users,gid=users,umask=0002 0 0

and it works! … just “Mountpoint” was wrong :slight_smile: