Can not mount hdd


I’m using opensuse 11.1 with gnome. From the beginning i’m using an external hdd without any problems. It’s an external hdd that i bought 2 years ago.
Today i bought a new external hdd, iomega select desktop hard drive 1TB usb 2.
But when i’m trying to use it, i always get the message:

Cannot mount volume.
Unable to mount the volume ‘iomega hdd’

DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

What can i do about that? Because i do not understand very well the explanations i’m finding on google.

THanks in advance.

The first thing IMHO to do is check that the drive was previously umounted properly under MS-Windows.

A couple of months ago I purchased a new hard drive and it gave me errors when I plugged it in under openSUSE. It was NTFS formatted.

So I then took it to an MS-Windows boot, plugged it in, and then properly unmounted it under MS-Windows.

I then took it back to the openSUSE Linux PC, and it was then properly hot plug mounted.

When you are going to use it with Linux, why should you bother searching through the neighbourhood for am MS-Windows system?
Put an ext2 fs on it using YaST > Partitioning. I would do that with any new disk I bought, destroying everything that maybe left on it (not only when it is a second-hand one).

If all my relatives and friends used Linux, I probably would reformat my external drives to a Linux format.

However fairly frequently I end up exchanging large amounts of data with my friends relatives (such as home movies > 2GB in file size) and they can not read ext2 with their MS-Windows PCs. It is easiest if I stick with NTFS on the external hard drives.

I do that only on storage devices that I use for exchange. Not for other storage, being it ‘external’ or ‘internal’ to a cp box. (Or do I have a misunderstanding about what ‘external’ is in this context?).

I don’t think Knor79 gave us “a context” reference their planned external drive use.

In my case, my external drive use, I like to keep my external drives “multipurpose”.

There was a time when I kept an external drive formatted as ext3, and kept another external drive formatted as NTFS. However I found that a major pain, and far too constraining and far too time consuming. I constantly had to ask myself, is this home video (or set of files) to be shared? If so, put it on the NTFS. If not, put it on ext3.

It became an organization/categorization head ache for me. A big head ache and loss of time as I constantly was shuffling files back and forth between the external ext3 and the external NTFS.

As soon as the NTFS-3G driver appeared (providing reliable linux read/write to NTFS (providing Linux a >2GB file capability with a Windoze OS)), after a period of my own testing of NTFS-3G, I then reformatted all my external ext2/ext3 drives back to their original NTFS format. I have been happy with that approach since.

But thats just my approach, and I would not be surprised where others have different approaches that are far more suited to their use.

Of course everybody should decide for himself how to venture. But often the knowledge that should go into the decision process is missing. There is at least one thread just solved, where somebody did a backup to a non-linux fs without explaining this. It came out to be the crucial source of the problem. As long as people do not even contemplate the pros/cons of using non-linux fss, I try to point to those. Not especialy you, as I know you know how to avoid a head ache (by using the right brand of beer, sorry fs). My post was for pointing out at those who read this:

. that finding a MS-windows for connecting - disconnecting might not be that easy (I banned it from the home and talked my friends into openSUSE);

. that reformatting a newly aquired disk might not be a bad idea (in whatever fs);

. that contemplaiting about what the disk is going to be used for, and thus maybe making it a real linux disk (and may be having more partitions on it) might be better than just ‘take it as it is because it was like that when I bought it’ (that would be like ‘I use Vista because it was on the system when I bought it’, not something we promote IMHO).

Thats a very good point !!

I typically dont back up all of my / but only backup selected files from that, and also only back up selected data from my /home.

Typically I have a second (somewhat older) Linux PC on our home LAN that is a “hot backup” with current data files/emails copied over fairly regularly on an adhoc manual basis. (Unfortunately that PC has been out on loan to friends for almost 2 months, and may be another month before I get it back). :slight_smile:

Still, even with that PC, I do put some backups on an external drive.

I don’t have my backups automated, but do it regularly on an adhoc basis as a matter of course, and typically backup my config files and emails to that other Linux PC on the home Lan (I now have to use my “sandbox/test” PC as my “hot backup”).

BUT if I were to use an external drive for backups on a more automated basis, I likely would re-look at having at least one of my external drives formatted in a Linux file format, to make the permissions and automation aspects to backups a lot easier.

Ofcourse i would like a external hdd that is multipurpose, but linux only is also good. I just want to use my new disk.
So i checked my external hdd and it was ntfs.
But it still wouldn’t mount.
So i tried to format it with yast 2 - partitioning to ext3.
In the middle of the format my pc gave an error -3035 or something and than it continuous to format the disk.
Now i can see that my external hdd is formatted to ext3, but when i try to use it, i still get the message that my pc can’t mount the hdd.
What do i do wrong?
What can i do to mount it?
Is it usefull to reinstall opensuse 11.1 with my external disks attached to my pc?


First, let me say if it was me, I would NOT have reformatted the external hard drive. I have no idea if that affects the warantee, and there should be no need unless you are looking at automated backups of parts of your openSUSE where permissions are critical. I keep all my external drives as NTFS (for the reasons I noted above).

If you ever decide to sell or give this external drive away, not many are going to want an ext3 formatted drive, … not to mention the drive is now only use to a relatively small percentage of the world’s PC users.

Off the top of my head I do not know what that error message (that you encountered) means.

If the ext3 formatting finished successfully you may be able to mount it manually. Ensure there is NO entry for it in your /etc/fstab (and be CAREFUL as to any changes you make to that file). Then plug the external drive and if it is not hotplug automounted, type:
df -Th
su -c 'fdisk -l’and enter root password. note that is a lower case “L” with “fdisk”. That will give you information on your drive. Lets say it is /dev/sdd1.

As a regular user (not root), create a directory called /home/yourusername/externaldisk.

Then mount the external drive manually in a terminal with root permissions. I’m not at a Linux pc and my memory is fuzzy, but if it is ext3 I think it is easy to mount manually (assuming sdd1 - your case will be different) with:
mount /dev/sdd1 /home/yourusername/externaldisk
Once you get this functioning, you can use a more fancy mount command.

No. I recommend you do NOT have external drives connected when installing openSUSE.

When you ask YaST to ‘format’ a partition as ext3, you can als ask YaST at the same window to mount it at a place of your choice. Did you do that? And when not, why? That is the easiest way of doing this for a non CLI oriented person.

And as you say “i still get the message that my pc can’t mount the hdd.”. But you do tell nothing on what you did, in a GUI, the CLI? When on the CLI it is very, very easy to cut and paste what you did and what you got as messages into your post. This has the advantage that we can realy see what happens and do not depend on what you describe vaguely.

Typo. That should have read:
mount /dev/sdd1 /home/yourusername/externaldisk

All right, I will retry it tonight and i will post everything here so you can see what is happening.