can not lauch neither yast2 nor one-click-install

when i click YaST from kickoff start menu, yast2 can not be lauched.
when i run /usr/sbin/yast2 the following error occur:

> /usr/sbin/yast2
Cannot mix incompatible Qt library (version 0x50302) with this library (version 0x50401)
/usr/sbin/yast2: 行 440: 3130 Aborted $y2ccbin $Y2UI_ARGS “$@”

when i right-click a ymp i have downloaded into my local filesystem and open with yast 1-click-install, it do not show any window and can not continue.

Open a terminal and post the result of

zypper lr -d

http://pastebin.com/raw.php?i=uLsRGYNQ

zypper lr -d http://pastebin.com/raw.php?i=uLsRGYNQ

and i found when i open ymp files with yast 1-click-install, there is y2sygnal.log file along with the ymp file . y2sygnal.log file’s contents follows:

http://paste.opensuse.org/view/raw/73153797

Honestly, that’s a pretty big list of repos and it doesn’t surprise me you have problems

kde3, really?

My advice is do some housekeeping and bring things back to nearer pure 13.2

You can start yast from a terminal to get basic form of it

su -
yast

Or just use zypper

zypper command works well for me , but i just wanna fix things right you know.
i added kde3 repo just because i wanna a pure kde or qt ftp client such as kftp-grabber.
anyway i will try to clean out some repos even though i dont think my problem’s key is related to this.

Problem is, not just that the repos are there, but that you have given your system the option of multiple versions of the same file.

So, just removing a repo is not enough. You need to get your system back to a more pure 13.2
Adding repos is fine, but the more you add, the more likely it can all go wrong, depending on experience.

To my eye,
In your original post the QT versions are close, but not exact.

I’d guess getting your entire system in sync might only require a system update, run the following

zypper up

TSU

this didn’t solve my problem. thanks anyway.

all packages whose name contains qt3:

> rpm -qa|grep qt3
qt3-3.3.8c-135.1.3.x86_64
libqt4-qt3support-4.8.6-4.4.1.x86_64

i tried to remove qt3 package but it is needed by google chrome.

all packages whose name contains qt4:

> rpm -qa|grep qt4
libqt4-4.8.6-4.4.1.x86_64
libpoppler-qt4-4-0.26.5-3.1.x86_64
qt4-qtscript-0.2.0-10.1.9.x86_64
fcitx-qt4-4.2.8.5-4.1.x86_64
libtelepathy-qt4-2-0.9.5-1.3.x86_64
libpackagekitqt4-0-0.9.2-2.1.x86_64
pinentry-qt4-0.8.4-1.1.x86_64
libqt4-sql-mysql-4.8.6-4.4.1.x86_64
libqt4-x11-4.8.6-4.4.1.x86_64
python3-qt4-4.11.2-145.2.x86_64
libqt4-qt3support-4.8.6-4.4.1.x86_64
python-qt4-4.11.1-2.2.4.x86_64
libqt4-sql-4.8.6-4.4.1.x86_64
libqt4-sql-sqlite-4.8.6-4.4.1.x86_64

there is no any pkgs whose name contains kde3.

when i ran baka-mplayer there is the same error:

> baka-mplayer Cannot mix incompatible Qt library (version 0x50302) with this library (version 0x50401)

i know baka-mplayer is based on qt5 , and the error information contains 0x50302 and 0x50401. so i guess maybe its related to qt5 packages. so i ran:

> rpm -qa|grep -i qt5
libQt5Widgets5-5.3.2-12.2.x86_64
libQt5Network5-5.4.1-19.1.x86_64
libQt5DBus5-5.4.1-19.1.x86_64
libQt5WebChannel5-5.4.1-4.1.x86_64
libQt5WebKitWidgets5-5.3.2-2.3.x86_64
libQt5X11Extras5-5.3.2-1.2.x86_64
libQt5Sensors5-5.4.1-6.1.x86_64
libQt5PrintSupport5-5.3.2-12.2.x86_64
libQt5Script5-5.3.2-1.6.x86_64
libQt5Test5-5.4.1-19.1.x86_64
libQt5XmlPatterns5-5.4.1-6.1.x86_64
libQt5WebChannel5-imports-5.4.1-4.1.x86_64
libQt5Sql5-sqlite-5.4.1-19.1.x86_64
libQt5Sensors5-imports-5.4.1-6.1.x86_64
libqt5-qtimageformats-5.3.2-1.1.x86_64
fcitx-qt5-0.1.2-15.1.x86_64
libQt5Core5-5.4.1-19.1.x86_64
libQt5Positioning5-5.4.1-6.1.x86_64
libQt5WebKit5-5.3.2-2.3.x86_64
libQt5OpenGL5-5.3.2-12.2.x86_64
libQt5Gui5-5.3.2-12.2.x86_64
libQt5Sql5-5.4.1-19.1.x86_64

it seems my guess is right. then i update this 5.3.2(0x50302) packages to 5.4.1(0x50401) , then my problem is solved. thanks god!

but why not these qt5 packages are updated to 5.4.1? because fcitx-qt5-0.1.2-15.1.x86_64 depends on libQt5Gui5 = 5.3.2 and this stops some qt5 packages being updated.