Can not install from LiveCD at all

Hello all,

I have surfed these forums over the last few days and have found some answers but nothing that fixes my problem. I know this problem has had some attention on the Gnome LiveCD but I can not install with either CD.
When I setup my install on a fresh hard drive I click the final Install button I get the system error -3008 Can not format swap as device is busy. It is mounting the newly created partition before it is formatted. I have disabled the autofs and haldeamon’s as this was suggested in another post.

I am at a loss. It seems that I can not install 11.1 at all. Trying to install with the 64 bit Live CD.

Commands used to disable autofs and hal:

/etc/init.d/autofs stop
/etc/rc.d/autofs stop
/etc/init.d/haldaemon stop

lsmod |grep autofs (returns nothing in the modules)

Not sure where to go from here as I have tried both the KDE and Gnome installs.

Thanks in advance for the help!

I face the same issue while installing Gnome desktop of mounting b4 formating.
So what i did is:
1- B4 installation, open Yast and create your partitions.
2- Then do the rest of installation part till partition, when reach there, choose create new partition and just set mount point for all and if u wana format it, you can.

On this way, i hope it will go smoothly.
Give it a shoot and let us know.

Thank you for your quick reply.

I have tried that to a point. I went in created the partitions under fdisk and then tried to use those partitions but to no avail. Haven’t tried using the Yast partitioner yet. Just went straight to fdisk as it has always been my fall back.

Any other ideas while I try Yast?




Unfortunatly partitioning with Yast first didn’t work. I was still given the same error. So I rebooted and tried the installer again on the already created partitions and was foiled yet again.

I am going to post the output of a few commands and maybe we can find a solution. If not I may need to fall back to 11.0.

If you need anything else let me know.


Troublesome error:
System Error caode was: -3009
/sbin/mkswap ‘/dev/sda1’:
/dev/sda1: Device or resource busy

Command output:
umount -a
/dev/: device is busy

**mount **
/proc on /proc tyoe proc (rw)
sysfs on /sys type sysfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0602,gid=5

mkswap /dev/sda1
/dev/sda1: device or resource busy

> /dev/sda1: Device or resource busy

where did you get that live CD? did you download it from or where?

are you absolutely certain that your install media has zero errors?

did you md5sum check the downloaded .iso prior to burning the disk?

did you check the disk itself prior to beginning the install?

see for more info on those three above…

i ask those questions because i have never heard of an openSUSE (or
SuSE, or SLED/S) install script error which would cause any on disk
partition to be mounted prior to the completion of all
partitioning/formatting steps–that is, something is VERY wrong with
your install!!

you wrote “When I setup my install on a fresh hard drive” does that
mean you put a new, empty hard drive into a machine as its ONLY
disk…OR did you add it as an additional hard drive?

are there any other operating systems on any hard drive connected
internally or externally?

if there are multiple drives and/or multiple operating systems then
you need to say so…

did you boot from the Live CD and then click on the desktop’s Install
icon? or what?

you might note that most folks here suggest the best way to install
is with a DVD…you might wanna try that…and make SURE you have good

can you please boot the live cd, open a terminal, become root, mount
your hard drive(s), run the following and post the output of these

uname -a

fdisk -l [that is a lower case L as in lemon]

df --print-type

cat /proc/partitions

and, just go ahead and tell us more about your system please…

/( )