can not enable desktop effects

When i enable desktop effects through simple compizconfig setting manager i got this message:“Desktop effects are not supported on your current hardware / configuration. Would you like to activate them anyway?” i installed the driver and video card is GEFORE 9300m GS, Operating System: Open SUSE 11.3. how can i resolve it? thx

I can only assume the nVIDIA proprietary driver is not really installed, otherwise 3D support would be present. If you look into the “My Computer” icon, what does the display info say? Here is a look at mine:

            Display Info

   Vendor:  nVidia Corporation
    Model:  GTX 560
2D driver:  nvidia
3D driver:  NVIDIA 275.09.07

I always install the nVIDIA driver the Hard Way using the most recent driver and I always run the 64 bit version. I go here and get the most recent driver and download it to my PC:

NVIDIA DRIVERS 275.09.07 Certified

Here is the article I would look at about installing the nVIDIA driver the hard way:

SDB:NVIDIA the hard way - openSUSE

In order to allow the nVIDIA driver to compile, I suggest that you do the following:

Open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:


[X] Base Development
[X] Linux Kernel Development
[X] C/C++ Development

Then Press the Accept button on the bottom right and allow these applications to install.

I always add the nomodeset kernel load option to my grub menu.lst file for my normal openSUSE OS selection menu. I always restart openSUSE and at the OS selection menu, I enter the kernel load option 3 to load the kernel and then switch to runlevel 3, thus not loading the desktop. The nomodeset command was already added to my grub menu before I did a reboot. I have a bash script file that can be used to install the nVIDIA proprietary video driver. You can find it here in message #12:

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Page 2

Let me know if you have any other questions with this procedure I have prescribed.

Thank You,